summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-21 18:30:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-21 18:30:55 +0000
commit1e1e1590c53d5b86b0a0ce723c49b215138f1888 (patch)
tree2ebee4316eaf3dc49d4d99bd9ee9092a65f19c45 /dev-python/mocker
parentStable for HPPA (bug #320967). (diff)
downloadgentoo-2-1e1e1590c53d5b86b0a0ce723c49b215138f1888.tar.gz
gentoo-2-1e1e1590c53d5b86b0a0ce723c49b215138f1888.tar.bz2
gentoo-2-1e1e1590c53d5b86b0a0ce723c49b215138f1888.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/mocker')
-rw-r--r--dev-python/mocker/ChangeLog10
-rw-r--r--dev-python/mocker/mocker-1.0.ebuild31
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-python/mocker/ChangeLog b/dev-python/mocker/ChangeLog
index 65da25208cc4..aef67a85d977 100644
--- a/dev-python/mocker/ChangeLog
+++ b/dev-python/mocker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/mocker
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mocker/ChangeLog,v 1.3 2009/10/10 17:54:20 grobian Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mocker/ChangeLog,v 1.4 2010/06/21 18:30:55 arfrever Exp $
+
+*mocker-1.0 (21 Jun 2010)
+
+ 21 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +mocker-1.0.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
10 Oct 2009; Fabian Groffen <grobian@gentoo.org> mocker-0.10.1.ebuild:
Merge from Prefix
diff --git a/dev-python/mocker/mocker-1.0.ebuild b/dev-python/mocker/mocker-1.0.ebuild
new file mode 100644
index 000000000000..64ce9cfd8374
--- /dev/null
+++ b/dev-python/mocker/mocker-1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mocker/mocker-1.0.ebuild,v 1.1 2010/06/21 18:30:55 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Platform for Python test doubles: mocks, stubs, fakes, and dummies"
+HOMEPAGE="http://labix.org/mocker http://pypi.python.org/pypi/mocker"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+PYTHON_MODNAME="mocker.py"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test.py
+ }
+ python_execute_function testing
+}