summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-08-09 17:41:19 +0000
committerMichał Górny <mgorny@gentoo.org>2011-08-09 17:41:19 +0000
commit3bdf81f879374fb2e1798f48f2cd868741d2659e (patch)
treedcd3d38a9da42cc023add385dc2430279d2bc4a1 /dev-python/miniupnpc/miniupnpc-1.6.ebuild
parentBased on 2.6.32.43 + genpatches-2.6.32-40 + grsecurity-2.2.2-2.6.32.43-201108... (diff)
downloadgentoo-2-3bdf81f879374fb2e1798f48f2cd868741d2659e.tar.gz
gentoo-2-3bdf81f879374fb2e1798f48f2cd868741d2659e.tar.bz2
gentoo-2-3bdf81f879374fb2e1798f48f2cd868741d2659e.zip
Split the Python module in net-libs/miniupnpc into separate dev-python/miniupnpc; link the Python module against shared libminiupnpc.
(Portage version: 2.2.0_alpha50_p1/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/miniupnpc/miniupnpc-1.6.ebuild')
-rw-r--r--dev-python/miniupnpc/miniupnpc-1.6.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/miniupnpc/miniupnpc-1.6.ebuild b/dev-python/miniupnpc/miniupnpc-1.6.ebuild
new file mode 100644
index 000000000000..7bfacd49241f
--- /dev/null
+++ b/dev-python/miniupnpc/miniupnpc-1.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/miniupnpc/miniupnpc-1.6.ebuild,v 1.1 2011/08/09 17:41:19 mgorny Exp $
+
+EAPI=3
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND=2
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit base distutils
+
+DESCRIPTION="UPnP client library and a simple UPnP client"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( >=net-libs/miniupnpc-1.6-r1
+ net-libs/miniupnpc[-python] )
+ !net-libs/miniupnpc[python]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/0001-Link-Python-module-against-the-shared-library.patch
+ )
+
+ base_src_prepare
+ distutils_src_prepare
+
+ # these will conflict with base miniupnpc ebuild
+ # and distutils.eclass is stupid enough to force installing them
+ rm -f Changelog.txt README || die
+}