summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-07-08 15:58:31 +0000
committerIan Delaney <idella4@gentoo.org>2013-07-08 15:58:31 +0000
commit654e1d8f43d0556e75de3ea7b644513f3c916c2e (patch)
tree399b63645539fa7c760ce6e32e609d3dcf38b4ab /dev-python/manuel
parentStable for HPPA (bug #475884). (diff)
downloadgentoo-2-654e1d8f43d0556e75de3ea7b644513f3c916c2e.tar.gz
gentoo-2-654e1d8f43d0556e75de3ea7b644513f3c916c2e.tar.bz2
gentoo-2-654e1d8f43d0556e75de3ea7b644513f3c916c2e.zip
upgrade ebuild, make in source build, fix test phase, add py3.3 support
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/manuel')
-rw-r--r--dev-python/manuel/ChangeLog5
-rw-r--r--dev-python/manuel/manuel-1.7.1.ebuild15
2 files changed, 11 insertions, 9 deletions
diff --git a/dev-python/manuel/ChangeLog b/dev-python/manuel/ChangeLog
index 46e47a59e6a5..7a764de25545 100644
--- a/dev-python/manuel/ChangeLog
+++ b/dev-python/manuel/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/manuel
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/manuel/ChangeLog,v 1.8 2013/05/10 05:18:49 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/manuel/ChangeLog,v 1.9 2013/07/08 15:58:31 idella4 Exp $
+
+ 08 Jul 2013; Ian Delaney <idella4@gentoo.org> manuel-1.7.1.ebuild:
+ upgrade ebuild, make in source build, fix test phase, add py3.3 support
10 May 2013; Patrick Lauer <patrick@gentoo.org> manuel-1.7.1.ebuild:
Fix inherit
diff --git a/dev-python/manuel/manuel-1.7.1.ebuild b/dev-python/manuel/manuel-1.7.1.ebuild
index 491e5e972b77..1d0c2ccfac21 100644
--- a/dev-python/manuel/manuel-1.7.1.ebuild
+++ b/dev-python/manuel/manuel-1.7.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/manuel/manuel-1.7.1.ebuild,v 1.3 2013/05/10 05:18:49 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/manuel/manuel-1.7.1.ebuild,v 1.4 2013/07/08 15:58:31 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python2_{6,7} python{3_1,3_2} pypy{1_9,2_0} )
+PYTHON_COMPAT=( python2_{6,7} python{3_1,3_2,3_3} pypy{1_9,2_0} )
inherit distutils-r1 eutils
@@ -15,19 +15,18 @@ SRC_URI="http://dev.gentoo.org/~idella4/tarballs/${P}-20130316.tar.bz2"
LICENSE="ZPL"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
+IUSE=""
RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
+# Required to run tests
+DISTUTILS_IN_SOURCE_BUILD=1
DOCS=( CHANGES.txt )
-src_prepare() {
- # Extract all refs to and use of zope.testing
- epatch "${FILESDIR}"/${PN}-1.7-rm_zope_test.patch
-}
+PATCHES=( "${FILESDIR}"/${PN}-1.7-rm_zope_test.patch )
python_test() {
- PYTHONPATH=${BUILD_DIR}/lib esetup.py test
+ PYTHONPATH=src/ esetup.py test
}