summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-11-24 16:02:53 +0000
committerMike Gilbert <floppym@gentoo.org>2014-11-24 16:02:53 +0000
commitdb9e52c5e00f29a7b9766e7a718efb44cb1df69d (patch)
tree13e602ccabac701da23a5a16f8b34e1413076643 /dev-python/lxml
parentRemove vulnerable ebuilds now that stabilisation is complete. For security bu... (diff)
downloadgentoo-2-db9e52c5e00f29a7b9766e7a718efb44cb1df69d.tar.gz
gentoo-2-db9e52c5e00f29a7b9766e7a718efb44cb1df69d.tar.bz2
gentoo-2-db9e52c5e00f29a7b9766e7a718efb44cb1df69d.zip
Convert hard-coded python_targets to python_gen_cond_dep calls.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/lxml')
-rw-r--r--dev-python/lxml/ChangeLog6
-rw-r--r--dev-python/lxml/lxml-3.3.5.ebuild6
-rw-r--r--dev-python/lxml/lxml-3.3.6.ebuild6
-rw-r--r--dev-python/lxml/lxml-3.4.0.ebuild6
-rw-r--r--dev-python/lxml/lxml-3.4.1.ebuild6
5 files changed, 17 insertions, 13 deletions
diff --git a/dev-python/lxml/ChangeLog b/dev-python/lxml/ChangeLog
index 339458182848..71ac01aa9af1 100644
--- a/dev-python/lxml/ChangeLog
+++ b/dev-python/lxml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/lxml
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/ChangeLog,v 1.205 2014/11/24 15:22:10 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/ChangeLog,v 1.206 2014/11/24 16:02:53 floppym Exp $
+
+ 24 Nov 2014; Mike Gilbert <floppym@gentoo.org> lxml-3.3.5.ebuild,
+ lxml-3.3.6.ebuild, lxml-3.4.0.ebuild, lxml-3.4.1.ebuild:
+ Convert hard-coded python_targets to python_gen_cond_dep calls.
24 Nov 2014; Rick Farina <zerochaos@gentoo.org> lxml-3.3.5.ebuild,
lxml-3.3.6.ebuild, lxml-3.4.0.ebuild:
diff --git a/dev-python/lxml/lxml-3.3.5.ebuild b/dev-python/lxml/lxml-3.3.5.ebuild
index 0a025e3a8d9b..0f8ea0043f7e 100644
--- a/dev-python/lxml/lxml-3.3.5.ebuild
+++ b/dev-python/lxml/lxml-3.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-3.3.5.ebuild,v 1.12 2014/11/24 15:22:10 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-3.3.5.ebuild,v 1.13 2014/11/24 16:02:53 floppym Exp $
EAPI=5
@@ -21,8 +21,8 @@ RDEPEND="
>=dev-libs/libxml2-2.7.2
>=dev-libs/libxslt-1.1.15
beautifulsoup3? (
- python_targets_python2_7? ( dev-python/beautifulsoup:python-2[python_targets_python2_7] )
- python_targets_python3_3? ( dev-python/beautifulsoup:python-3[python_targets_python3_3] )
+ $(python_gen_cond_dep 'dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/beautifulsoup:python-3[${PYTHON_USEDEP}]' 'python3*')
)"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/lxml/lxml-3.3.6.ebuild b/dev-python/lxml/lxml-3.3.6.ebuild
index 201367eafdd3..328f6f41b80c 100644
--- a/dev-python/lxml/lxml-3.3.6.ebuild
+++ b/dev-python/lxml/lxml-3.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-3.3.6.ebuild,v 1.2 2014/11/24 15:22:10 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-3.3.6.ebuild,v 1.3 2014/11/24 16:02:53 floppym Exp $
EAPI=5
@@ -21,8 +21,8 @@ RDEPEND="
>=dev-libs/libxml2-2.7.2
>=dev-libs/libxslt-1.1.15
beautifulsoup3? (
- python_targets_python2_7? ( dev-python/beautifulsoup:python-2[python_targets_python2_7] )
- python_targets_python3_3? ( dev-python/beautifulsoup:python-3[python_targets_python3_3] )
+ $(python_gen_cond_dep 'dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/beautifulsoup:python-3[${PYTHON_USEDEP}]' 'python3*')
)"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/lxml/lxml-3.4.0.ebuild b/dev-python/lxml/lxml-3.4.0.ebuild
index 9ee5ffc479fe..05c130747394 100644
--- a/dev-python/lxml/lxml-3.4.0.ebuild
+++ b/dev-python/lxml/lxml-3.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-3.4.0.ebuild,v 1.2 2014/11/24 15:22:10 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-3.4.0.ebuild,v 1.3 2014/11/24 16:02:53 floppym Exp $
EAPI=5
@@ -21,8 +21,8 @@ RDEPEND="
>=dev-libs/libxml2-2.7.2
>=dev-libs/libxslt-1.1.23
beautifulsoup3? (
- python_targets_python2_7? ( dev-python/beautifulsoup:python-2[python_targets_python2_7] )
- python_targets_python3_3? ( dev-python/beautifulsoup:python-3[python_targets_python3_3] )
+ $(python_gen_cond_dep 'dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/beautifulsoup:python-3[${PYTHON_USEDEP}]' 'python3*')
)"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/lxml/lxml-3.4.1.ebuild b/dev-python/lxml/lxml-3.4.1.ebuild
index 55464be7f017..750ccfad5c6e 100644
--- a/dev-python/lxml/lxml-3.4.1.ebuild
+++ b/dev-python/lxml/lxml-3.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-3.4.1.ebuild,v 1.1 2014/11/21 07:54:01 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-3.4.1.ebuild,v 1.2 2014/11/24 16:02:53 floppym Exp $
EAPI=5
@@ -21,8 +21,8 @@ RDEPEND="
>=dev-libs/libxml2-2.7.2
>=dev-libs/libxslt-1.1.23
beautifulsoup3? (
- python_targets_python2_7? ( dev-python/beautifulsoup:python-2[python_targets_python2_7] )
- python_targets_python3_3? ( dev-python/beautifulsoup:python-3[python_targets_python3_3] )
+ $(python_gen_cond_dep 'dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/beautifulsoup:python-3[${PYTHON_USEDEP}]' 'python3*')
)"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"