summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-01 14:00:43 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-01 14:00:43 +0000
commit7d143364ed6e000f5d1a18131039e240822f6b41 (patch)
tree7ea0b12c5f96cc27d9aa3cca975b0d0432f25c22 /dev-python/kaa-base
parentSparc stable, bug #264503. (diff)
downloadgentoo-2-7d143364ed6e000f5d1a18131039e240822f6b41.tar.gz
gentoo-2-7d143364ed6e000f5d1a18131039e240822f6b41.tar.bz2
gentoo-2-7d143364ed6e000f5d1a18131039e240822f6b41.zip
Adding dev-lang/python[threads] dep. Fixes #264471
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/kaa-base')
-rw-r--r--dev-python/kaa-base/ChangeLog9
-rw-r--r--dev-python/kaa-base/kaa-base-0.4.0-r1.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-python/kaa-base/ChangeLog b/dev-python/kaa-base/ChangeLog
index fed5a49f2a49..0ed4bae5bd4f 100644
--- a/dev-python/kaa-base/ChangeLog
+++ b/dev-python/kaa-base/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/kaa-base
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-base/ChangeLog,v 1.15 2008/08/23 11:49:55 rbu Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-base/ChangeLog,v 1.16 2009/04/01 14:00:43 patrick Exp $
+
+*kaa-base-0.4.0-r1 (01 Apr 2009)
+
+ 01 Apr 2009; Patrick Lauer <patrick@gentoo.org> +kaa-base-0.4.0-r1.ebuild:
+ Adding dev-lang/python[threads] dep. Fixes #264471
23 Aug 2008; Robert Buchholz <rbu@gentoo.org> kaa-base-0.4.0.ebuild:
Pull avahi and others into DEPEND, and check for avahi before checking for
diff --git a/dev-python/kaa-base/kaa-base-0.4.0-r1.ebuild b/dev-python/kaa-base/kaa-base-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..70f45c1c43d8
--- /dev/null
+++ b/dev-python/kaa-base/kaa-base-0.4.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-base/kaa-base-0.4.0-r1.ebuild,v 1.1 2009/04/01 14:00:43 patrick Exp $
+
+EAPI="2"
+
+inherit python eutils distutils
+
+DESCRIPTION="Basic Framework for all Kaa Python Modules."
+HOMEPAGE="http://freevo.sourceforge.net/kaa/"
+SRC_URI="mirror://sourceforge/freevo/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="avahi ssl sqlite tls lirc"
+
+DEPEND="dev-lang/python[threads]
+ dev-libs/libxml2
+ sqlite? ( dev-python/dbus-python >=dev-python/pysqlite-2.2 )
+ avahi? ( net-dns/avahi )"
+RDEPEND="${DEPEND}
+ dev-python/pynotifier
+ lirc? ( dev-python/pylirc )
+ tls? ( dev-python/tlslite )"
+
+PYTHON_MODNAME="kaa"
+
+src_unpack() {
+ distutils_src_unpack
+
+ cd "${S}"
+ rm -rf src/notifier/pynotifier
+}
+
+pkg_setup() {
+ if ! built_with_use dev-libs/libxml2 python; then
+ eerror "dev-libs/libxml2 must be built with the 'python' USE flag"
+ die "Recompile dev-libs/libxml2 with the 'python' USE flag enabled"
+ fi
+ if use avahi && ! built_with_use net-dns/avahi python; then
+ eerror "net-dns/avahi must be built with the 'python' USE flag"
+ die "Recompile net-dns/avahi with the 'python' USE flag enabled"
+ fi
+}