summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-09-02 20:01:45 +0000
committerMike Gilbert <floppym@gentoo.org>2013-09-02 20:01:45 +0000
commit68c7c2394ec63bc2f7d748c0b5cd3f4cf4e02ecd (patch)
tree7a1b9a0038436b1a3dd7e8527a4cb6067e63a7bd /dev-python/http-parser
parentTemporarily mask libsecret-0.16 due to API/ABI change (bug #483414). (diff)
downloadgentoo-2-68c7c2394ec63bc2f7d748c0b5cd3f4cf4e02ecd.tar.gz
gentoo-2-68c7c2394ec63bc2f7d748c0b5cd3f4cf4e02ecd.tar.bz2
gentoo-2-68c7c2394ec63bc2f7d748c0b5cd3f4cf4e02ecd.zip
Version bump. add python3.3.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/http-parser')
-rw-r--r--dev-python/http-parser/ChangeLog7
-rw-r--r--dev-python/http-parser/http-parser-0.8.3.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/http-parser/ChangeLog b/dev-python/http-parser/ChangeLog
index bd7858205d5c..b754256aacea 100644
--- a/dev-python/http-parser/ChangeLog
+++ b/dev-python/http-parser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/http-parser
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/http-parser/ChangeLog,v 1.16 2013/07/11 21:30:47 vincent Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/http-parser/ChangeLog,v 1.17 2013/09/02 20:01:45 floppym Exp $
+
+*http-parser-0.8.3 (02 Sep 2013)
+
+ 02 Sep 2013; Mike Gilbert <floppym@gentoo.org> +http-parser-0.8.3.ebuild:
+ Version bump. add python3.3.
11 Jul 2013; Vicente Olivert Riera <vincent@gentoo.org>
http-parser-0.8.1-r1.ebuild:
diff --git a/dev-python/http-parser/http-parser-0.8.3.ebuild b/dev-python/http-parser/http-parser-0.8.3.ebuild
new file mode 100644
index 000000000000..68ec48ccbd8e
--- /dev/null
+++ b/dev-python/http-parser/http-parser-0.8.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/http-parser/http-parser-0.8.3.ebuild,v 1.1 2013/09/02 20:01:45 floppym Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="HTTP request/response parser for python in C"
+HOMEPAGE="http://github.com/benoitc/http-parser"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+cython_dep() {
+ local flag
+ for flag in $(python_gen_useflags 'python*'); do
+ DEPEND+=" ${flag}? ( dev-python/cython[${flag}(-)] )"
+ done
+}
+cython_dep
+
+python_compile() {
+ if [[ ${EPYTHON} != python3* ]]; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_install_all() {
+ local DOCS=( README.rst )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}