summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-07-17 13:05:46 +0000
committerIan Delaney <idella4@gentoo.org>2015-07-17 13:05:46 +0000
commit29c70e796dab0fe2e1cf66381f223f4fd733f4d8 (patch)
tree7e7512734007e45edfb23623cc80eef66b271762 /dev-python/hiredis
parentia64 stable wrt bug #552160 (diff)
downloadgentoo-2-29c70e796dab0fe2e1cf66381f223f4fd733f4d8.tar.gz
gentoo-2-29c70e796dab0fe2e1cf66381f223f4fd733f4d8.tar.bz2
gentoo-2-29c70e796dab0fe2e1cf66381f223f4fd733f4d8.zip
bump; patch to remove vendor and var 'lib' from setup.py
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/hiredis')
-rw-r--r--dev-python/hiredis/ChangeLog8
-rw-r--r--dev-python/hiredis/files/hiredis-0.2.0-system-libs.patch28
-rw-r--r--dev-python/hiredis/hiredis-0.2.0.ebuild29
3 files changed, 64 insertions, 1 deletions
diff --git a/dev-python/hiredis/ChangeLog b/dev-python/hiredis/ChangeLog
index 72e8a93e66b6..04987b07ce66 100644
--- a/dev-python/hiredis/ChangeLog
+++ b/dev-python/hiredis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/hiredis
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hiredis/ChangeLog,v 1.13 2015/06/07 13:30:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hiredis/ChangeLog,v 1.14 2015/07/17 13:05:46 idella4 Exp $
+
+*hiredis-0.2.0 (17 Jul 2015)
+
+ 17 Jul 2015; Ian Delaney <idella4@gentoo.org>
+ +files/hiredis-0.2.0-system-libs.patch, +hiredis-0.2.0.ebuild:
+ bump; patch to remove vendor and var 'lib' from setup.py
07 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-python/hiredis/files/hiredis-0.2.0-system-libs.patch b/dev-python/hiredis/files/hiredis-0.2.0-system-libs.patch
new file mode 100644
index 000000000000..6cd22292deb9
--- /dev/null
+++ b/dev-python/hiredis/files/hiredis-0.2.0-system-libs.patch
@@ -0,0 +1,28 @@
+Remove vendor and var 'lib' from setup.py
+diff -u hiredis-0.2.0.orig/setup.py hiredis-0.2.0/setup.py
+--- setup.py 2015-06-21 11:47:28.796472027 +0800
++++ setup.py 2015-06-21 11:49:53.047949803 +0800
+@@ -40,12 +40,9 @@
+ # supported Python versions is worse...
+ #
+ # Also see: https://github.com/pietern/hiredis-py/issues/15
+-lib = ("hiredis_for_hiredis_py", {
+- "sources": ["vendor/hiredis/%s.c" % src for src in ("read", "sds")]})
+
+ ext = Extension("hiredis.hiredis",
+- sources=glob.glob("src/*.c"),
+- include_dirs=["vendor"])
++ sources=glob.glob("src/*.c"))
+
+ setup(
+ name="hiredis",
+@@ -57,7 +54,6 @@
+ keywords=["Redis"],
+ license="BSD",
+ packages=["hiredis"],
+- libraries=[lib],
+ ext_modules=[ext],
+
+ # Override "install_lib" command
+Common subdirectories: hiredis-0.2.0.orig/src and hiredis-0.2.0/src
+Common subdirectories: hiredis-0.2.0.orig/vendor and hiredis-0.2.0/vendor
diff --git a/dev-python/hiredis/hiredis-0.2.0.ebuild b/dev-python/hiredis/hiredis-0.2.0.ebuild
new file mode 100644
index 000000000000..3e25f4ba8eb3
--- /dev/null
+++ b/dev-python/hiredis/hiredis-0.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hiredis/hiredis-0.2.0.ebuild,v 1.1 2015/07/17 13:05:46 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python extension that wraps hiredis"
+HOMEPAGE="https://github.com/pietern/hiredis-py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/hiredis-0.13.1"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-system-libs.patch )
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+ distutils-r1_python_compile
+}