summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-06 10:28:39 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-06 10:28:39 +0000
commitbea4c0e8f2c36ea71aa9d754f01c69efd0ecb259 (patch)
tree086811508d93ed9e9f9b2b04fad71612a1a7a417 /dev-python/gst-python
parentRemove old (diff)
downloadgentoo-2-bea4c0e8f2c36ea71aa9d754f01c69efd0ecb259.tar.gz
gentoo-2-bea4c0e8f2c36ea71aa9d754f01c69efd0ecb259.tar.bz2
gentoo-2-bea4c0e8f2c36ea71aa9d754f01c69efd0ecb259.zip
Version bump. Updated to 1.0 gstreamer slot, but testsuite is missing.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-python/gst-python')
-rw-r--r--dev-python/gst-python/ChangeLog9
-rw-r--r--dev-python/gst-python/gst-python-1.2.0.ebuild59
2 files changed, 66 insertions, 2 deletions
diff --git a/dev-python/gst-python/ChangeLog b/dev-python/gst-python/ChangeLog
index d6e6b2281f49..16a24bfeda7f 100644
--- a/dev-python/gst-python/ChangeLog
+++ b/dev-python/gst-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/gst-python
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/ChangeLog,v 1.129 2013/10/22 07:20:09 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/ChangeLog,v 1.130 2014/04/06 10:28:39 eva Exp $
+
+*gst-python-1.2.0 (06 Apr 2014)
+
+ 06 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org> +gst-python-1.2.0.ebuild:
+ Version bump. Updated to 1.0 gstreamer slot, but testsuite is missing.
22 Oct 2013; Agostino Sarubbo <ago@gentoo.org> gst-python-0.10.22-r1.ebuild:
Stable for sparc, wrt bug #480908
diff --git a/dev-python/gst-python/gst-python-1.2.0.ebuild b/dev-python/gst-python/gst-python-1.2.0.ebuild
new file mode 100644
index 000000000000..ba7fa85f33da
--- /dev/null
+++ b/dev-python/gst-python/gst-python-1.2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-1.2.0.ebuild,v 1.1 2014/04/06 10:28:39 eva Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit python-r1
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="examples test"
+
+RDEPEND="
+ dev-libs/libxml2
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=media-libs/gstreamer-1.2:1.0
+ >=media-libs/gst-plugins-base-1.2:1.0
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+# XXX: unittests are not ported to 1.0 yet.
+
+src_prepare() {
+ # Leave examples alone
+ sed -e 's/\(SUBDIRS = .*\)examples/\1/' \
+ -i Makefile.am Makefile.in || die
+
+ prepare_gst() {
+ mkdir -p "${BUILD_DIR}" || die
+ }
+ python_foreach_impl prepare_gst
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir econf
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir default
+ prune_libtool_files --modules
+ einstalldocs
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*
+ fi
+}