summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-03-28 14:16:43 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-03-28 14:16:43 +0000
commitc528b974446bc87f860604a410b1b4a9c0d0f77d (patch)
treebbaa7d37cfe51843a39eb84f80896a16b207ccad /dev-python/gnome-python-extras
parentxulrunner flag for gnome-python-desktop; add it to 2.18 mask (diff)
downloadgentoo-2-c528b974446bc87f860604a410b1b4a9c0d0f77d.tar.gz
gentoo-2-c528b974446bc87f860604a410b1b4a9c0d0f77d.tar.bz2
gentoo-2-c528b974446bc87f860604a410b1b4a9c0d0f77d.zip
Bump with xulrunner support for Gnome 2.18.0
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-python/gnome-python-extras')
-rw-r--r--dev-python/gnome-python-extras/ChangeLog8
-rw-r--r--dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.14.2-r13
-rw-r--r--dev-python/gnome-python-extras/gnome-python-extras-2.14.2-r1.ebuild76
3 files changed, 86 insertions, 1 deletions
diff --git a/dev-python/gnome-python-extras/ChangeLog b/dev-python/gnome-python-extras/ChangeLog
index daec204c722d..0bdbef533a1a 100644
--- a/dev-python/gnome-python-extras/ChangeLog
+++ b/dev-python/gnome-python-extras/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gnome-python-extras
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/ChangeLog,v 1.46 2007/02/17 00:03:06 eroyf Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/ChangeLog,v 1.47 2007/03/28 14:16:43 dang Exp $
+
+*gnome-python-extras-2.14.2-r1 (28 Mar 2007)
+
+ 28 Mar 2007; Daniel Gryniewicz <dang@gentoo.org>
+ +gnome-python-extras-2.14.2-r1.ebuild:
+ Bump with xulrunner support for Gnome 2.18.0
17 Feb 2007; Alexander H. Færøy <eroyf@gentoo.org> metadata.xml:
Removed allanonjl from metadata.xml
diff --git a/dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.14.2-r1 b/dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.14.2-r1
new file mode 100644
index 000000000000..f756dc74dabf
--- /dev/null
+++ b/dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.14.2-r1
@@ -0,0 +1,3 @@
+MD5 039e1300368df17de9867685e9705091 gnome-python-extras-2.14.2.tar.bz2 351780
+RMD160 d2707eee20a103f070455fef3bd9cddc1060ce93 gnome-python-extras-2.14.2.tar.bz2 351780
+SHA256 fcecd0098431c0baca72cc762560b15f330275727df4fd4157606a90252bae29 gnome-python-extras-2.14.2.tar.bz2 351780
diff --git a/dev-python/gnome-python-extras/gnome-python-extras-2.14.2-r1.ebuild b/dev-python/gnome-python-extras/gnome-python-extras-2.14.2-r1.ebuild
new file mode 100644
index 000000000000..b4a9f0f637c8
--- /dev/null
+++ b/dev-python/gnome-python-extras/gnome-python-extras-2.14.2-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/gnome-python-extras-2.14.2-r1.ebuild,v 1.1 2007/03/28 14:16:43 dang Exp $
+
+NEED_PYTHON=2.4
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=1.9
+inherit eutils gnome2 python virtualx autotools
+
+DESCRIPTION="GNOME 2 Bindings for Python"
+HOMEPAGE="http://www.pygtk.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc firefox seamonkey xulrunner"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.6
+ >=dev-python/gnome-python-2.10
+ >=dev-python/pygtk-2.4
+ =gnome-extra/gtkhtml-2.6*
+ xulrunner? ( net-libs/xulrunner )
+ !xulrunner? ( firefox? ( >=www-client/mozilla-firefox-1.0 ) )
+ !xulrunner? ( !firefox? ( seamonkey? ( >=www-client/seamonkey-1.0 ) ) )
+ >=gnome-extra/libgda-1.2.0
+ >=app-text/gtkspell-2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README"
+
+pkg_setup() {
+ # only controls linking, can't disable w/o a patch :)
+ if use xulrunner; then
+ G2CONF="${G2CONF} --with-gtkmozembed=xulrunner"
+ elif use firefox; then
+ G2CONF="${G2CONF} --with-gtkmozembed=firefox"
+ elif use seamonkey; then
+ G2CONF="${G2CONF} --with-gtkmozembed=seamonkey"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # change mozilla to seamonkey
+ sed -i -e 's:1.2b):1.0.0):;s:mozilla):seamonkey):' configure.ac
+
+ eautoreconf
+}
+
+src_test() {
+ Xmake check || die "tests failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0"
+}
+