summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-13 09:22:14 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-13 09:22:14 +0000
commita888f3cd2159f34888ed6523b0f5fceb861c60ae (patch)
tree628173460f7100c027c6278ff8767ae8060c9941 /dev-python/gnome-python-extras-base
parentRemove also graphite useflag. (diff)
downloadgentoo-2-a888f3cd2159f34888ed6523b0f5fceb861c60ae.tar.gz
gentoo-2-a888f3cd2159f34888ed6523b0f5fceb861c60ae.tar.bz2
gentoo-2-a888f3cd2159f34888ed6523b0f5fceb861c60ae.zip
Finally fix horribly slow python libs detection (bug #344231).
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/gnome-python-extras-base')
-rw-r--r--dev-python/gnome-python-extras-base/ChangeLog7
-rw-r--r--dev-python/gnome-python-extras-base/files/gnome-python-extras-base-2.25.3-python-libs.patch59
-rw-r--r--dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3.ebuild14
3 files changed, 76 insertions, 4 deletions
diff --git a/dev-python/gnome-python-extras-base/ChangeLog b/dev-python/gnome-python-extras-base/ChangeLog
index 9ef1ce4526a3..87a9ceb9aa44 100644
--- a/dev-python/gnome-python-extras-base/ChangeLog
+++ b/dev-python/gnome-python-extras-base/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/gnome-python-extras-base
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras-base/ChangeLog,v 1.23 2012/05/04 15:12:12 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras-base/ChangeLog,v 1.24 2012/08/13 09:22:14 tetromino Exp $
+
+ 13 Aug 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ gnome-python-extras-base-2.25.3.ebuild,
+ +files/gnome-python-extras-base-2.25.3-python-libs.patch:
+ Finally fix horribly slow python libs detection (bug #344231).
04 May 2012; Patrick Lauer <patrick@gentoo.org>
gnome-python-extras-base-2.25.3.ebuild:
diff --git a/dev-python/gnome-python-extras-base/files/gnome-python-extras-base-2.25.3-python-libs.patch b/dev-python/gnome-python-extras-base/files/gnome-python-extras-base-2.25.3-python-libs.patch
new file mode 100644
index 000000000000..ab691272cbb6
--- /dev/null
+++ b/dev-python/gnome-python-extras-base/files/gnome-python-extras-base-2.25.3-python-libs.patch
@@ -0,0 +1,59 @@
+From 7824fd5291f570de3c2c64185035d1a6a0a3445a Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Mon, 13 Aug 2012 04:42:47 -0400
+Subject: [PATCH] Replace horrible slow python libs search
+
+---
+ acinclude.m4 | 36 ++----------------------------------
+ 1 files changed, 2 insertions(+), 34 deletions(-)
+
+diff --git a/acinclude.m4 b/acinclude.m4
+index 8694a65..f5373eb 100644
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -59,40 +59,8 @@ $1],dnl
+ [AC_MSG_RESULT(not found)
+ $2])
+ CPPFLAGS="$save_CPPFLAGS"
+-
+- # This bit is copied from Planner. murrayc.
+- # Check for Python library path
+- AC_MSG_CHECKING([for Python library path])
+-
+- # Win32 has libpython25.a instead of libpython2.5.a, so we look
+- # for both. TODO: Only look for libpython25.a on Windows, and for
+- # libpython2.5.a on unix.
+- WIN32_PYTHON_VERSION=`echo $PYTHON_VERSION | sed "s,\.,,"`
+-
+- python_path=`dirname $PYTHON | sed "s,/bin.*$,,"`
+- for i in "$python_path/lib/python$PYTHON_VERSION/config/" "$python_path/lib/python$PYTHON_VERSION/" "$python_path/lib/python/config/" "$python_path/lib/python/" "$python_path/" ; do
+- if test -e "$i"; then
+- python_path=`find $i -type f -name libpython$PYTHON_VERSION.* -print | sed "1q"`
+- if test -n "$python_path" ; then
+- python_lib="python$PYTHON_VERSION"
+- break
+- fi
+-
+- # Additionally test WIN32_PYTHON_VERSION
+- python_path=`find $i -type f -name libpython$WIN32_PYTHON_VERSION.* -print | sed "1q"`
+- if test -n "$python_path" ; then
+- python_lib="python$WIN32_PYTHON_VERSION"
+- break
+- fi
+- fi
+- done
+-
+- python_path=`echo $python_path | sed "s,/libpython.*$,,"`
+- AC_MSG_RESULT([$python_path])
+- if test -z "$python_path" ; then
+- AC_MSG_ERROR([cannot find Python library path])
+- fi
+- AC_SUBST([PYTHON_LDFLAGS],["-L$python_path -l$python_lib"])
++PYTHON_LDFLAGS=`$PYTHON -c "import distutils.sysconfig; print('-L%s -lpython${PYTHON_VERSION}' % distutils.sysconfig.get_config_var('LIBDIR'))"`
++AC_SUBST([PYTHON_LDFLAGS],["$PYTHON_LDFLAGS"])
+ ])
+
+ dnl
+--
+1.7.8.6
+
diff --git a/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3.ebuild b/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3.ebuild
index 8f2c5ed0b63a..952693c2b3fe 100644
--- a/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3.ebuild
+++ b/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3.ebuild,v 1.10 2012/05/04 15:12:12 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3.ebuild,v 1.11 2012/08/13 09:22:14 tetromino Exp $
EAPI="3"
PYTHON_DEPEND="2"
-inherit versionator eutils gnome2 python
+inherit versionator autotools eutils gnome2 python
# This ebuild does nothing -- we just want to get the pkgconfig file installed
MY_PN="gnome-python-extras"
@@ -25,7 +25,9 @@ RDEPEND=">=x11-libs/gtk+-2.4:2
>=dev-python/pygtk-2.10.3:2
!<=dev-python/gnome-python-extras-2.19.1-r2"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig
+ gnome-base/gnome-common"
+# eautoreconf needs gnome-base/gnome-common
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
@@ -38,3 +40,9 @@ pkg_setup() {
python_set_active_version 2
python_pkg_setup
}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python-libs.patch" #344231
+ eautoreconf
+ gnome2_src_prepare
+}