summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-17 18:38:37 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-17 18:38:37 +0000
commit24be69f2836bcc2f07300bb687bb63a421ba44c1 (patch)
tree265615e0d404e5989337bad07e0615630f7db34c /dev-python/gnome-python-base
parentVersion bump. (diff)
downloadgentoo-2-24be69f2836bcc2f07300bb687bb63a421ba44c1.tar.gz
gentoo-2-24be69f2836bcc2f07300bb687bb63a421ba44c1.tar.bz2
gentoo-2-24be69f2836bcc2f07300bb687bb63a421ba44c1.zip
Version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/gnome-python-base')
-rw-r--r--dev-python/gnome-python-base/ChangeLog8
-rw-r--r--dev-python/gnome-python-base/gnome-python-base-2.28.1.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/gnome-python-base/ChangeLog b/dev-python/gnome-python-base/ChangeLog
index 3464f5876685..0a042f8f288f 100644
--- a/dev-python/gnome-python-base/ChangeLog
+++ b/dev-python/gnome-python-base/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gnome-python-base
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-base/ChangeLog,v 1.25 2010/06/11 09:20:31 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-base/ChangeLog,v 1.26 2010/06/17 18:38:37 pacho Exp $
+
+*gnome-python-base-2.28.1 (17 Jun 2010)
+
+ 17 Jun 2010; Pacho Ramos <pacho@gentoo.org>
+ +gnome-python-base-2.28.1.ebuild:
+ Version bump
11 Jun 2010; Pacho Ramos <pacho@gentoo.org>
gnome-python-base-2.28.0.ebuild:
diff --git a/dev-python/gnome-python-base/gnome-python-base-2.28.1.ebuild b/dev-python/gnome-python-base/gnome-python-base-2.28.1.ebuild
new file mode 100644
index 000000000000..305bf05ba50f
--- /dev/null
+++ b/dev-python/gnome-python-base/gnome-python-base-2.28.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-base/gnome-python-base-2.28.1.ebuild,v 1.1 2010/06/17 18:38:37 pacho Exp $
+
+GCONF_DEBUG="no"
+
+inherit versionator eutils gnome2
+
+# This ebuild does nothing -- we just want to get the pkgconfig file installed
+
+MY_PN="gnome-python"
+DESCRIPTION="Provides the base files for the gnome-python bindings"
+HOMEPAGE="http://pygtk.org/"
+PVP="$(get_version_component_range 1-2)"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
+
+IUSE=""
+LICENSE="LGPL-2.1"
+SLOT="2"
+RESTRICT="${RESTRICT} test"
+
+# From the gnome-python eclass
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.6
+ >=dev-python/pygtk-2.14.0
+ >=dev-python/pygobject-2.17
+ !<dev-python/gnome-python-2.22.1"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-allbindings"
+}