summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-11-18 22:13:50 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-11-18 22:13:50 +0000
commit8b93ccb360b9d666541c9400075266c52fa6c5c5 (patch)
treeaf0eb748d68f3cccaf9a3a30b107cc6043ea3de9 /dev-python/glance_store
parentadding for glance (diff)
downloadgentoo-2-8b93ccb360b9d666541c9400075266c52fa6c5c5.tar.gz
gentoo-2-8b93ccb360b9d666541c9400075266c52fa6c5c5.tar.bz2
gentoo-2-8b93ccb360b9d666541c9400075266c52fa6c5c5.zip
adding for glance
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/glance_store')
-rw-r--r--dev-python/glance_store/ChangeLog9
-rw-r--r--dev-python/glance_store/Manifest3
-rw-r--r--dev-python/glance_store/glance_store-0.1.10.ebuild34
-rw-r--r--dev-python/glance_store/metadata.xml12
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/glance_store/ChangeLog b/dev-python/glance_store/ChangeLog
new file mode 100644
index 000000000000..51378252bf21
--- /dev/null
+++ b/dev-python/glance_store/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/glance_store
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/glance_store/ChangeLog,v 1.1 2014/11/18 22:13:50 prometheanfire Exp $
+
+*glance_store-0.1.10 (18 Nov 2014)
+
+ 18 Nov 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +glance_store-0.1.10.ebuild, +metadata.xml:
+ adding for glance
diff --git a/dev-python/glance_store/Manifest b/dev-python/glance_store/Manifest
new file mode 100644
index 000000000000..8605d254418f
--- /dev/null
+++ b/dev-python/glance_store/Manifest
@@ -0,0 +1,3 @@
+DIST glance_store-0.1.10.tar.gz 95520 SHA256 b390fea864f1398f79ab66ce99c3b868b86ac1bf97dbe89ba4498506e2af7d02 SHA512 cd4b2013c49c1104523c809ae28f8cb3fb927564d46db4cb36d5d7c529e69e684af584ad322786e41afc414770a750a545b1baea9f62f2d9611f165df0fc801f WHIRLPOOL d1c65c33eaec3710463fffbe2139fd72b98b3e3e1e722424d8051c0e28c8277e67c96b80476a4245bbd4f2279998b86a6fbd09361d5f73d46f4b80c2eabc5795
+EBUILD glance_store-0.1.10.ebuild 1078 SHA256 f2122603dc7862bacd12fd5d273585a54dd5e4ed84e2024b9c3e81d319945182 SHA512 784f5e4afd01605f2b21c97af9dfe5585e6c9afc253dc8efd8cedb67180096c536b7361751eb00dbef3d77c673909ff03959cae40adb496cde90d2a1c60a739d WHIRLPOOL 79a5834e8f5605726714dfbced874b4bc83ecc68a01116ea71ced2ca8a2b37ae047660b8d3e6dbb692b67298858dc528f15108a656dc99b0067f8d2f8b2fda49
+MISC metadata.xml 355 SHA256 5eb15ca599e6b10635dcd80f6da3d82064643e494c33ecc5174f638a532bf95d SHA512 36b8659bdf73c0479887ce5900568268aa3562a471e5f7523658251915de3d31dcdeed15892f9fc4b70d12fd07d0ad3340aae02e1ba8780a948cb70d8f152a99 WHIRLPOOL 9e7394e643edf20e9d2833ab874ee477c2fda21aab4d7d362672f84aef8ef9296a93b4b26c3459673c1e97cb328805793b5a6c4db3783a554a7812780a80777a
diff --git a/dev-python/glance_store/glance_store-0.1.10.ebuild b/dev-python/glance_store/glance_store-0.1.10.ebuild
new file mode 100644
index 000000000000..32b7439ddaaf
--- /dev/null
+++ b/dev-python/glance_store/glance_store-0.1.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/glance_store/glance_store-0.1.10.ebuild,v 1.1 2014/11/18 22:13:50 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A connection pool for python-ldap"
+HOMEPAGE="http://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/oslo-config-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-0.12[${PYTHON_USEDEP}]
+ >=dev-python/python-cinderclient-1.0.6[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.13.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/glance_store/metadata.xml b/dev-python/glance_store/metadata.xml
new file mode 100644
index 000000000000..3e102e5e67c4
--- /dev/null
+++ b/dev-python/glance_store/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openstack</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ A simple connector pool for python-ldap.
+ </longdescription>
+</pkgmetadata>