summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2009-07-22 00:32:48 +0000
committerJesus Rivero <neurogeek@gentoo.org>2009-07-22 00:32:48 +0000
commit8e5cc4638aa7da731727a52c21bdb2c7e4df471c (patch)
treeab1f08a9dcdb023bf2b39836cda70e85a5472689 /dev-python/genshi
parentCopy 1.6.3 to 1.6.3-r10 without changes. Disable KDE support in 1.6.3 to allo... (diff)
downloadgentoo-2-8e5cc4638aa7da731727a52c21bdb2c7e4df471c.tar.gz
gentoo-2-8e5cc4638aa7da731727a52c21bdb2c7e4df471c.tar.bz2
gentoo-2-8e5cc4638aa7da731727a52c21bdb2c7e4df471c.zip
Fixed tests. Closes bug #276299
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'dev-python/genshi')
-rw-r--r--dev-python/genshi/ChangeLog8
-rw-r--r--dev-python/genshi/files/genshi-0.5.1_test_fix.patch16
-rw-r--r--dev-python/genshi/genshi-0.5.1.ebuild11
3 files changed, 30 insertions, 5 deletions
diff --git a/dev-python/genshi/ChangeLog b/dev-python/genshi/ChangeLog
index 38b5173a8b96..4da132c23542 100644
--- a/dev-python/genshi/ChangeLog
+++ b/dev-python/genshi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/genshi
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/genshi/ChangeLog,v 1.16 2008/11/16 17:46:16 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/genshi/ChangeLog,v 1.17 2009/07/22 00:32:48 neurogeek Exp $
+
+ 22 Jul 2009; Jesus Rivero <neurogeek@gentoo.org> genshi-0.5.1.ebuild,
+ +files/genshi-0.5.1_test_fix.patch:
+ Fixed tests. Closes bug #276299
16 Nov 2008; Markus Meier <maekke@gentoo.org> genshi-0.5.1.ebuild:
amd64/x86 stable, bug #246130
diff --git a/dev-python/genshi/files/genshi-0.5.1_test_fix.patch b/dev-python/genshi/files/genshi-0.5.1_test_fix.patch
new file mode 100644
index 000000000000..0280b0a82bbb
--- /dev/null
+++ b/dev-python/genshi/files/genshi-0.5.1_test_fix.patch
@@ -0,0 +1,16 @@
+Added by: neurogeek@gentoo.org
+Reported to upstream: 21-Jul-2009
+Upstream ticket: http://genshi.edgewall.org/ticket/324
+
+diff -uNr Genshi-0.5.1.orig/genshi/template/eval.py Genshi-0.5.1/genshi/template/eval.py
+--- Genshi-0.5.1.orig/genshi/template/eval.py 2009-07-21 23:56:48.000000000 +0000
++++ Genshi-0.5.1/genshi/template/eval.py 2009-07-21 23:56:59.000000000 +0000
+@@ -229,8 +229,6 @@
+ >>> foo = Undefined('foo')
+ >>> bool(foo)
+ False
+- >>> list(foo)
+- []
+ >>> print foo
+ undefined
+
diff --git a/dev-python/genshi/genshi-0.5.1.ebuild b/dev-python/genshi/genshi-0.5.1.ebuild
index d27bf20978a8..5477ee14ba72 100644
--- a/dev-python/genshi/genshi-0.5.1.ebuild
+++ b/dev-python/genshi/genshi-0.5.1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/genshi/genshi-0.5.1.ebuild,v 1.5 2008/11/16 17:46:16 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/genshi/genshi-0.5.1.ebuild,v 1.6 2009/07/22 00:32:48 neurogeek Exp $
+EAPI="2"
NEED_PYTHON=2.3
inherit distutils
@@ -17,10 +18,14 @@ KEYWORDS="amd64 ppc ~ppc64 ~sparc x86"
IUSE="doc examples"
DEPEND="dev-python/setuptools"
-RDEPEND="${DEPEND}"
+RDEPEND=""
S="${WORKDIR}/${MY_P}"
+src_prepare(){
+ epatch "${FILESDIR}/${P}_test_fix.patch"
+}
+
src_install() {
distutils_src_install