summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-11-24 12:44:48 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-11-24 12:44:48 +0000
commit162883cd017f1db55e6becca1b5a928ca713a4cf (patch)
treec43a289ce74a8d1021a05494c800e3c9621a2bea /dev-python/gdl-python
parentEmpty bump to try and make packages.gentoo.org happy again. (diff)
downloadgentoo-2-162883cd017f1db55e6becca1b5a928ca713a4cf.tar.gz
gentoo-2-162883cd017f1db55e6becca1b5a928ca713a4cf.tar.bz2
gentoo-2-162883cd017f1db55e6becca1b5a928ca713a4cf.zip
Fix build failure with recent gdl
(Portage version: 2.2_rc15/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'dev-python/gdl-python')
-rw-r--r--dev-python/gdl-python/ChangeLog8
-rw-r--r--dev-python/gdl-python/files/gdl-python-2.19.1-gdlicons.patch15
-rw-r--r--dev-python/gdl-python/gdl-python-2.19.1-r1.ebuild47
3 files changed, 69 insertions, 1 deletions
diff --git a/dev-python/gdl-python/ChangeLog b/dev-python/gdl-python/ChangeLog
index 36eb4782baab..1eb80c2ba4c6 100644
--- a/dev-python/gdl-python/ChangeLog
+++ b/dev-python/gdl-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gdl-python
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdl-python/ChangeLog,v 1.2 2008/10/27 01:21:31 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdl-python/ChangeLog,v 1.3 2008/11/24 12:44:48 eva Exp $
+
+*gdl-python-2.19.1-r1 (24 Nov 2008)
+
+ 24 Nov 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/gdl-python-2.19.1-gdlicons.patch, +gdl-python-2.19.1-r1.ebuild:
+ Fix build failure with recent gdl.
27 Oct 2008; Ali Polatel <hawking@gentoo.org> gdl-python-2.19.1.ebuild:
Use python_need_rebuild.
diff --git a/dev-python/gdl-python/files/gdl-python-2.19.1-gdlicons.patch b/dev-python/gdl-python/files/gdl-python-2.19.1-gdlicons.patch
new file mode 100644
index 000000000000..6ef9680be994
--- /dev/null
+++ b/dev-python/gdl-python/files/gdl-python-2.19.1-gdlicons.patch
@@ -0,0 +1,15 @@
+Debian #500767
+GNOME #553911
+
+Index: b/gdl/gdl.override
+===================================================================
+--- a/gdl/gdl.override 2008-10-01 11:16:02.455827766 +0200
++++ b/gdl/gdl.override 2008-10-01 11:16:17.847329409 +0200
+@@ -6,7 +6,6 @@ headers
+ #include <pygtk/pygtk.h>
+ #include <gdl/gdl-dock.h>
+ #include <gdl/libgdltypebuiltins.h>
+-#include <gdl/gdl-icons.h>
+ #ifndef HAVE_GDL_0_7
+ # include <gdl/gdl-dock-bar.h>
+ #endif
diff --git a/dev-python/gdl-python/gdl-python-2.19.1-r1.ebuild b/dev-python/gdl-python/gdl-python-2.19.1-r1.ebuild
new file mode 100644
index 000000000000..81d345f34b73
--- /dev/null
+++ b/dev-python/gdl-python/gdl-python-2.19.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdl-python/gdl-python-2.19.1-r1.ebuild,v 1.1 2008/11/24 12:44:48 eva Exp $
+
+G_PY_PN="gnome-python-extras"
+
+inherit gnome-python-common python
+
+PVP="$(get_version_component_range 1-2)"
+SRC_URI="mirror://gnome/sources/${G_PY_PN}/${PVP}/${G_PY_PN}-${PV}.tar.bz2
+ mirror://gentoo/${G_PY_PN}-${PV}-split.patch.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-libs/gdl-0.6.1"
+DEPEND="${RDEPEND}"
+
+EXAMPLES="examples/gdl/*"
+
+pkg_setup() {
+ # we need gdl-gnome
+ if ! built_with_use --missing true dev-libs/gdl gnome; then
+ eerror "If you want to build ${PN} you need to build dev-libs/gdl with"
+ eerror "the the 'gnome' USE flag."
+ die "gdl must be built with USE='gnome'"
+ fi
+
+ gnome-python-common_pkg_setup
+}
+
+src_unpack() {
+ gnome-python-common_src_unpack
+
+ epatch "${WORKDIR}/${G_PY_PN}-${PV}-split.patch"
+ eautoreconf
+
+ # Fix build failure with recent gdl
+ epatch "${FILESDIR}/${P}-gdlicons.patch"
+}
+
+src_install() {
+ python_need_rebuild
+ gnome-python-common_src_install
+}