summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-14 08:22:31 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-14 08:22:31 +0000
commitb3856a6946f21d02329f94cc0ccf47691de8cb28 (patch)
tree9fe30852a8b7e48e58aa4e1fdd0ee5c00afe4e9d /dev-python/gdata
parentMake jfsutils-1.1.15 stable on alpha (bug 473238) (diff)
downloadgentoo-2-b3856a6946f21d02329f94cc0ccf47691de8cb28.tar.gz
gentoo-2-b3856a6946f21d02329f94cc0ccf47691de8cb28.tar.bz2
gentoo-2-b3856a6946f21d02329f94cc0ccf47691de8cb28.zip
revbump; migrate -> distutils-r1
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/gdata')
-rw-r--r--dev-python/gdata/ChangeLog7
-rw-r--r--dev-python/gdata/gdata-2.0.17-r1.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/gdata/ChangeLog b/dev-python/gdata/ChangeLog
index f6567d1c979b..e353594e1457 100644
--- a/dev-python/gdata/ChangeLog
+++ b/dev-python/gdata/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/gdata
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/ChangeLog,v 1.108 2013/06/01 11:15:58 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/ChangeLog,v 1.109 2013/06/14 08:22:31 idella4 Exp $
+
+*gdata-2.0.17-r1 (14 Jun 2013)
+
+ 14 Jun 2013; Ian Delaney <idella4@gentoo.org> +gdata-2.0.17-r1.ebuild:
+ revbump; migrate -> distutils-r1
01 Jun 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due bug #144305
diff --git a/dev-python/gdata/gdata-2.0.17-r1.ebuild b/dev-python/gdata/gdata-2.0.17-r1.ebuild
new file mode 100644
index 000000000000..00dd2ac48626
--- /dev/null
+++ b/dev-python/gdata/gdata-2.0.17-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/gdata-2.0.17-r1.ebuild,v 1.1 2013/06/14 08:22:31 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy2_0 )
+PYTHON_REQ_USE="ssl(+),xml(+)"
+
+inherit distutils-r1
+
+MY_P="gdata-${PV}"
+
+DESCRIPTION="Python client library for Google data APIs"
+HOMEPAGE="http://code.google.com/p/gdata-python-client/ http://pypi.python.org/pypi/gdata"
+SRC_URI="http://gdata-python-client.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="examples"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ # run_service_tests.py requires interaction (and a valid Google account), so skip it.
+ "${PYTHON}" tests/run_data_tests.py -v || die "Test failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( samples/. )
+ distutils-r1_python_install_all
+}