summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-06-23 11:15:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-06-23 11:15:32 +0000
commit71029a4cf4440834e8a83fb23915622a6ea0c6bd (patch)
tree9bbc000c5c1c76e2ee0c85b87f65f6d43c7b1107 /dev-python/gdata
parentBump to 1.480, fixes #274845 (diff)
downloadgentoo-2-71029a4cf4440834e8a83fb23915622a6ea0c6bd.tar.gz
gentoo-2-71029a4cf4440834e8a83fb23915622a6ea0c6bd.tar.bz2
gentoo-2-71029a4cf4440834e8a83fb23915622a6ea0c6bd.zip
Bump to 1.3.3, fixes #274892. Small fixes by Rodrigo Lazo
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/gdata')
-rw-r--r--dev-python/gdata/ChangeLog7
-rw-r--r--dev-python/gdata/gdata-1.3.3.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/gdata/ChangeLog b/dev-python/gdata/ChangeLog
index cfbf33acbb49..b869d501c43b 100644
--- a/dev-python/gdata/ChangeLog
+++ b/dev-python/gdata/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/gdata
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/ChangeLog,v 1.20 2009/04/28 12:02:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/ChangeLog,v 1.21 2009/06/23 11:15:32 patrick Exp $
+
+*gdata-1.3.3 (23 Jun 2009)
+
+ 23 Jun 2009; Patrick Lauer <patrick@gentoo.org> +gdata-1.3.3.ebuild:
+ Bump to 1.3.3, fixes #274892. Small fixes by Rodrigo Lazo
28 Apr 2009; Raúl Porcel <armin76@gentoo.org> gdata-1.0.8.ebuild:
arm stable
diff --git a/dev-python/gdata/gdata-1.3.3.ebuild b/dev-python/gdata/gdata-1.3.3.ebuild
new file mode 100644
index 000000000000..e74383ef6b85
--- /dev/null
+++ b/dev-python/gdata/gdata-1.3.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/gdata-1.3.3.ebuild,v 1.1 2009/06/23 11:15:32 patrick Exp $
+
+inherit distutils eutils
+
+MY_P="gdata-${PV}"
+
+DESCRIPTION="Python client library for Google data APIs"
+HOMEPAGE="http://code.google.com/p/gdata-python-client/"
+SRC_URI="http://gdata-python-client.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="|| ( >=dev-lang/python-2.5 dev-python/elementtree )"
+
+PYTHON_MODNAME="atom gdata"
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+ fi
+}
+
+src_test() {
+ cd tests
+ export PYTHONPATH=../src
+ "${python}" run_data_tests.py -v || die "Data tests failed"
+
+ # run_service_tests.py requires interaction (and a valid google account), so skip.
+ #"${python}" run_service_tests.py -v || die "Service tests failed"
+}