summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-26 23:09:27 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-26 23:09:27 +0000
commit7589b5c0b9929b4bf51becc12715d6822f6a5f90 (patch)
tree25b605c5eb8bea89e0ec44b38213c2a01e1fa5fe /dev-python/gdata/gdata-2.0.14.ebuild
parentversion bump (diff)
downloadgentoo-2-7589b5c0b9929b4bf51becc12715d6822f6a5f90.tar.gz
gentoo-2-7589b5c0b9929b4bf51becc12715d6822f6a5f90.tar.bz2
gentoo-2-7589b5c0b9929b4bf51becc12715d6822f6a5f90.zip
Version bump.
(Portage version: 2.2.0_alpha28_p34/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/gdata/gdata-2.0.14.ebuild')
-rw-r--r--dev-python/gdata/gdata-2.0.14.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/gdata/gdata-2.0.14.ebuild b/dev-python/gdata/gdata-2.0.14.ebuild
new file mode 100644
index 000000000000..ac28d196d0e7
--- /dev/null
+++ b/dev-python/gdata/gdata-2.0.14.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/gdata-2.0.14.ebuild,v 1.1 2011/03/26 23:09:27 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_P="gdata-${PV}"
+
+DESCRIPTION="Python client library for Google data APIs"
+HOMEPAGE="http://code.google.com/p/gdata-python-client/ http://pypi.python.org/pypi/gdata"
+SRC_URI="http://gdata-python-client.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+DEPEND="|| ( dev-lang/python:2.7[xml] dev-lang/python:2.6[xml] dev-lang/python:2.5[xml] dev-python/elementtree )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="atom gdata"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" tests/run_data_tests.py -v || return 1
+
+ # run_service_tests.py requires interaction (and a valid Google account), so skip it.
+ # PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" tests/run_service_tests.py -v || return 1
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r samples/* || die "Installation of examples failed"
+ fi
+}