summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-04 18:47:20 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-04 18:47:20 +0000
commit2f3b5de777551b8b033382b4d748c8c499688f7d (patch)
tree58842d87a08e5b1565634d2b9778ef77e16eb783 /dev-python/fusil
parenttaxbird version bump (diff)
downloadgentoo-2-2f3b5de777551b8b033382b4d748c8c499688f7d.tar.gz
gentoo-2-2f3b5de777551b8b033382b4d748c8c499688f7d.tar.bz2
gentoo-2-2f3b5de777551b8b033382b4d748c8c499688f7d.zip
Delete older ebuild.
Diffstat (limited to 'dev-python/fusil')
-rw-r--r--dev-python/fusil/fusil-1.3.1.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/fusil/fusil-1.3.1.ebuild b/dev-python/fusil/fusil-1.3.1.ebuild
deleted file mode 100644
index db7857da4224..000000000000
--- a/dev-python/fusil/fusil-1.3.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/fusil-1.3.1.ebuild,v 1.1 2009/11/15 17:50:32 arfrever Exp $
-
-EAPI="2"
-NEED_PYTHON="2.5"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="Fusil the fuzzer is a Python library used to write fuzzing programs."
-HOMEPAGE="http://bitbucket.org/haypo/fusil/wiki/Home http://pypi.python.org/pypi/fusil"
-SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
-
-DEPEND=">=dev-python/python-ptrace-0.6"
-RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="2.4"
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-
-src_prepare() {
- python_copy_sources --no-link
-
- conversion() {
- [[ "${PYTHON_ABI}" == 2.* ]] && return
-
- 2to3-${PYTHON_ABI} -w . fuzzers/fusil-* fuzzers/notworking/fusil-* > /dev/null
- epatch python3.0.patch
- }
- python_execute_function --action-message 'Applying patches for Python ${PYTHON_ABI}' --failure-message 'Applying patches for Python ${PYTHON_ABI} failed' -s conversion
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- cd doc
- emake RST2HTML="rst2html.py" || die "Generation of documentation failed"
- fi
-}
-
-src_install(){
- distutils_src_install
-
- if use doc; then
- dohtml doc/*
- fi
-
- if use examples; then
- insinto "/usr/share/doc/${PF}"
- doins -r examples
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- enewgroup fusil
- enewuser fusil -1 -1 -1 "fusil"
-}