summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-15 17:50:32 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-15 17:50:32 +0000
commit0141ad601027f3a4c2191ba47bedfc21a75d4896 (patch)
treecaa6efdcf0d957d6ffdab7ce402c7119bf17dd60 /dev-python/fusil
parentVersion bump. (diff)
downloadgentoo-2-0141ad601027f3a4c2191ba47bedfc21a75d4896.tar.gz
gentoo-2-0141ad601027f3a4c2191ba47bedfc21a75d4896.tar.bz2
gentoo-2-0141ad601027f3a4c2191ba47bedfc21a75d4896.zip
Version bump.
(Portage version: 14821-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/fusil')
-rw-r--r--dev-python/fusil/ChangeLog8
-rw-r--r--dev-python/fusil/fusil-1.3.1.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/dev-python/fusil/ChangeLog b/dev-python/fusil/ChangeLog
index 63f0b9516c69..21a37750091e 100644
--- a/dev-python/fusil/ChangeLog
+++ b/dev-python/fusil/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/fusil
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/ChangeLog,v 1.3 2009/09/18 13:41:09 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/ChangeLog,v 1.4 2009/11/15 17:50:32 arfrever Exp $
+
+*fusil-1.3.1 (15 Nov 2009)
+
+ 15 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +fusil-1.3.1.ebuild:
+ Version bump.
*fusil-1.3 (18 Sep 2009)
diff --git a/dev-python/fusil/fusil-1.3.1.ebuild b/dev-python/fusil/fusil-1.3.1.ebuild
new file mode 100644
index 000000000000..db7857da4224
--- /dev/null
+++ b/dev-python/fusil/fusil-1.3.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/fusil-1.3.1.ebuild,v 1.1 2009/11/15 17:50:32 arfrever Exp $
+
+EAPI="2"
+NEED_PYTHON="2.5"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Fusil the fuzzer is a Python library used to write fuzzing programs."
+HOMEPAGE="http://bitbucket.org/haypo/fusil/wiki/Home http://pypi.python.org/pypi/fusil"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND=">=dev-python/python-ptrace-0.6"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="2.4"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
+src_prepare() {
+ python_copy_sources --no-link
+
+ conversion() {
+ [[ "${PYTHON_ABI}" == 2.* ]] && return
+
+ 2to3-${PYTHON_ABI} -w . fuzzers/fusil-* fuzzers/notworking/fusil-* > /dev/null
+ epatch python3.0.patch
+ }
+ python_execute_function --action-message 'Applying patches for Python ${PYTHON_ABI}' --failure-message 'Applying patches for Python ${PYTHON_ABI} failed' -s conversion
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ cd doc
+ emake RST2HTML="rst2html.py" || die "Generation of documentation failed"
+ fi
+}
+
+src_install(){
+ distutils_src_install
+
+ if use doc; then
+ dohtml doc/*
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}"
+ doins -r examples
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ enewgroup fusil
+ enewuser fusil -1 -1 -1 "fusil"
+}