summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-30 13:09:16 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-30 13:09:16 +0000
commitd8939d0d18ae86743a6f3b6994ff8040dbef5a7c (patch)
tree1b1c7b892577e721a5d4f38b0ca23eae1328b16b /dev-python/formencode
parentAdd missing bug 553638 reference (diff)
downloadgentoo-2-d8939d0d18ae86743a6f3b6994ff8040dbef5a7c.tar.gz
gentoo-2-d8939d0d18ae86743a6f3b6994ff8040dbef5a7c.tar.bz2
gentoo-2-d8939d0d18ae86743a6f3b6994ff8040dbef5a7c.zip
Don't install docs into side-packages, bug #553638
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python/formencode')
-rw-r--r--dev-python/formencode/ChangeLog8
-rw-r--r--dev-python/formencode/formencode-1.2.6-r1.ebuild35
-rw-r--r--dev-python/formencode/formencode-1.3.0-r1.ebuild (renamed from dev-python/formencode/formencode-1.3.0.ebuild)9
3 files changed, 14 insertions, 38 deletions
diff --git a/dev-python/formencode/ChangeLog b/dev-python/formencode/ChangeLog
index b0e6c0e82aa8..07a42eb31085 100644
--- a/dev-python/formencode/ChangeLog
+++ b/dev-python/formencode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/formencode
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/formencode/ChangeLog,v 1.36 2015/04/08 08:05:27 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/formencode/ChangeLog,v 1.37 2015/06/30 13:09:16 jlec Exp $
+
+*formencode-1.3.0-r1 (30 Jun 2015)
+
+ 30 Jun 2015; Justin Lecher <jlec@gentoo.org> +formencode-1.3.0-r1.ebuild,
+ -formencode-1.2.6-r1.ebuild, -formencode-1.3.0.ebuild:
+ Don't install docs into side-packages, bug #553638
08 Apr 2015; Michał Górny <mgorny@gentoo.org> formencode-1.2.6-r1.ebuild:
Drop old Python implementations
diff --git a/dev-python/formencode/formencode-1.2.6-r1.ebuild b/dev-python/formencode/formencode-1.2.6-r1.ebuild
deleted file mode 100644
index 094e9922ec1f..000000000000
--- a/dev-python/formencode/formencode-1.2.6-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/formencode/formencode-1.2.6-r1.ebuild,v 1.6 2015/04/08 08:05:27 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-MY_PN="FormEncode"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="HTML form validation, generation, and conversion package"
-HOMEPAGE="http://formencode.org/ http://pypi.python.org/pypi/FormEncode"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
- # https://bugs.gentoo.org/show_bug.cgi?id=473154
-# test? ( dev-python/nose[${PYTHON_USEDEP}]
-# dev-python/pycountry[${PYTHON_USEDEP}]
-# dev-python/pydns[${PYTHON_USEDEP}] )"
-RDEPEND=""
-RESTRICT="test"
-DOCS=( docs/{index.txt,modules.txt} )
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/formencode/formencode-1.3.0.ebuild b/dev-python/formencode/formencode-1.3.0-r1.ebuild
index 3f0dc3537dd3..9a805bcdaa4e 100644
--- a/dev-python/formencode/formencode-1.3.0.ebuild
+++ b/dev-python/formencode/formencode-1.3.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/formencode/formencode-1.3.0.ebuild,v 1.2 2015/03/11 04:28:40 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/formencode/formencode-1.3.0-r1.ebuild,v 1.1 2015/06/30 13:09:16 jlec Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
@@ -26,11 +26,16 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
RDEPEND=""
RESTRICT="test"
-DOCS=( docs/{index.txt,modules.txt} )
+DOCS=( docs/. )
S="${WORKDIR}/${MY_P}"
DISTUTILS_IN_SOURCE_BUILD=1
+python_prepare_all() {
+ sed -e '/package_data.*..docs/d' -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
python_test() {
# https://github.com/formencode/formencode/issues/78
# 5 failures under py2.7. Although the package claims to cater to py3, the suite fails horribly