summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-20 07:43:31 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-20 07:43:31 +0000
commitad8c2e2ff827f9bf81674ee01ff9ea10c14bb52a (patch)
treefe5f19d2ff09e083cf3c67643293acfa2d9c950d /dev-python/flask-security
parentDepend on virtual/libintl rather than sys-devel/gettext (bug #499774). (diff)
downloadgentoo-2-ad8c2e2ff827f9bf81674ee01ff9ea10c14bb52a.tar.gz
gentoo-2-ad8c2e2ff827f9bf81674ee01ff9ea10c14bb52a.tar.bz2
gentoo-2-ad8c2e2ff827f9bf81674ee01ff9ea10c14bb52a.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/flask-security')
-rw-r--r--dev-python/flask-security/ChangeLog7
-rw-r--r--dev-python/flask-security/flask-security-1.7.2.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-python/flask-security/ChangeLog b/dev-python/flask-security/ChangeLog
index 5d88f7ae4338..ed147053986f 100644
--- a/dev-python/flask-security/ChangeLog
+++ b/dev-python/flask-security/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-security
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-security/ChangeLog,v 1.3 2014/01/28 06:42:08 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-security/ChangeLog,v 1.4 2014/05/20 07:43:31 patrick Exp $
+
+*flask-security-1.7.2 (20 May 2014)
+
+ 20 May 2014; Patrick Lauer <patrick@gentoo.org> +flask-security-1.7.2.ebuild:
+ Bump
*flask-security-1.7.1 (28 Jan 2014)
diff --git a/dev-python/flask-security/flask-security-1.7.2.ebuild b/dev-python/flask-security/flask-security-1.7.2.ebuild
new file mode 100644
index 000000000000..6a5a7a4ba835
--- /dev/null
+++ b/dev-python/flask-security/flask-security-1.7.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-security/flask-security-1.7.2.ebuild,v 1.1 2014/05/20 07:43:31 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Flask-Security"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple security for Flask apps"
+HOMEPAGE="http://pythonhosted.org/${MY_PN}/ https://pypi.python.org/pypi/${MY_PN}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# packages of this type require local running instances of databases
+# which then require connect to localhost
+RESTRICT="test"
+
+RDEPEND=">=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/flask-login-0.2.9[${PYTHON_USEDEP}]
+ >=dev-python/flask-mail-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-wtf-0.9.3f[${PYTHON_USEDEP}]
+ >=dev-python/flask-principal-0.4.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/flask-mongoengine[${PYTHON_USEDEP}]
+ dev-python/flask-peewee[${PYTHON_USEDEP}]
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}