summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-20 07:46:18 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-20 07:46:18 +0000
commit45810cd1d8a597f2b637ad7ca68b5aabfcdfefca (patch)
treece50e85e659d42a3c37ff77a3a158c6d86c667ab /dev-python/flask-script
parentBump (diff)
downloadgentoo-2-45810cd1d8a597f2b637ad7ca68b5aabfcdfefca.tar.gz
gentoo-2-45810cd1d8a597f2b637ad7ca68b5aabfcdfefca.tar.bz2
gentoo-2-45810cd1d8a597f2b637ad7ca68b5aabfcdfefca.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/flask-script')
-rw-r--r--dev-python/flask-script/ChangeLog7
-rw-r--r--dev-python/flask-script/flask-script-2.0.5.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/flask-script/ChangeLog b/dev-python/flask-script/ChangeLog
index b4f7a060e51b..f8314977ed5f 100644
--- a/dev-python/flask-script/ChangeLog
+++ b/dev-python/flask-script/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-script
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/ChangeLog,v 1.15 2014/05/06 10:24:00 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/ChangeLog,v 1.16 2014/05/20 07:46:18 patrick Exp $
+
+*flask-script-2.0.5 (20 May 2014)
+
+ 20 May 2014; Patrick Lauer <patrick@gentoo.org> +flask-script-2.0.5.ebuild:
+ Bump
*flask-script-2.0.3 (06 May 2014)
diff --git a/dev-python/flask-script/flask-script-2.0.5.ebuild b/dev-python/flask-script/flask-script-2.0.5.ebuild
new file mode 100644
index 000000000000..b078a0898d7f
--- /dev/null
+++ b/dev-python/flask-script/flask-script-2.0.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/flask-script-2.0.5.ebuild,v 1.1 2014/05/20 07:46:18 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1
+
+MY_PN="Flask-Script"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flask support for writing external scripts."
+HOMEPAGE="http://packages.python.org/Flask-Script/ http://pypi.python.org/pypi/Flask-Script"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/flask-0.10.1-r1[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generation of documentation by" ${PYTHON}
+ PYTHONPATH=".." emake -C docs html || die "Generation of documentation failed"
+ fi
+}
+
+python_test() {
+ py.test tests.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}