summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-26 06:49:00 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-26 06:49:00 +0000
commit437be5893b2250f208941a177cbc7945a02276ff (patch)
treefb3d02f08f87720ea7cc6e8839c3bcdf78e05451 /dev-python/flask-restless
parentInitial import, dependency of flask-restless (diff)
downloadgentoo-2-437be5893b2250f208941a177cbc7945a02276ff.tar.gz
gentoo-2-437be5893b2250f208941a177cbc7945a02276ff.tar.bz2
gentoo-2-437be5893b2250f208941a177cbc7945a02276ff.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/flask-restless')
-rw-r--r--dev-python/flask-restless/ChangeLog7
-rw-r--r--dev-python/flask-restless/flask-restless-0.13.0.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-python/flask-restless/ChangeLog b/dev-python/flask-restless/ChangeLog
index f0e8a459fb36..c81e0c8c750e 100644
--- a/dev-python/flask-restless/ChangeLog
+++ b/dev-python/flask-restless/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-restless
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/ChangeLog,v 1.10 2014/05/06 10:13:21 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/ChangeLog,v 1.11 2014/05/26 06:49:00 patrick Exp $
+
+*flask-restless-0.13.0 (26 May 2014)
+
+ 26 May 2014; Patrick Lauer <patrick@gentoo.org> +flask-restless-0.13.0.ebuild:
+ Bump
*flask-restless-0.12.1 (06 May 2014)
diff --git a/dev-python/flask-restless/flask-restless-0.13.0.ebuild b/dev-python/flask-restless/flask-restless-0.13.0.ebuild
new file mode 100644
index 000000000000..ca89dd824524
--- /dev/null
+++ b/dev-python/flask-restless/flask-restless-0.13.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/flask-restless-0.13.0.ebuild,v 1.1 2014/05/26 06:49:00 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1
+
+DESCRIPTION="Flask extension for easy ReSTful API generation"
+HOMEPAGE="http://packages.python.org/Flask-Restless/"
+SRC_URI="https://github.com/jfinkels/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( AGPL-3 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/flask-0.7[${PYTHON_USEDEP}]
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil:0[${PYTHON_USEDEP}]
+ dev-python/mimerender[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( virtual/python-unittest2[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-httpdomain-1.1.7[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-issuetracker-0.11[${PYTHON_USEDEP}]
+ dev-python/flask-themes[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/mapping.patch )
+
+python_compile_all() {
+ if use doc; then
+ if ! "${PYTHON}" -c "import flask_restless"; then
+ eerror "flask-restless is not installed. Building of the docs"
+ eerror "requires flask-restless to be installed."
+ eerror "emerge with USE=-doc followed bu USE=doc"
+ die
+ fi
+ # Changes connect to read issues @ github
+ rm -f docs/changelog.rst
+ einfo "Generating html docs for ${PN}"
+ PYTHONPATH=${PYTHONPATH}"${S}"/docs emake -C docs html \
+ || die "Generating html docs for ${PN} failed"
+ fi
+}
+
+python_test() {
+ nosetests -w tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}