summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-02-15 06:44:59 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-02-15 06:44:59 +0000
commit84775b0dda9e1a1e1e7774df5fe571263c0062fc (patch)
tree7f5b1db2862792056f9df4423d3e2f06426b2d40 /dev-python/elasticsearch-py/elasticsearch-py-1.4.0.ebuild
parentBump (diff)
downloadgentoo-2-84775b0dda9e1a1e1e7774df5fe571263c0062fc.tar.gz
gentoo-2-84775b0dda9e1a1e1e7774df5fe571263c0062fc.tar.bz2
gentoo-2-84775b0dda9e1a1e1e7774df5fe571263c0062fc.zip
Bump
(Portage version: 2.2.17/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/elasticsearch-py/elasticsearch-py-1.4.0.ebuild')
-rw-r--r--dev-python/elasticsearch-py/elasticsearch-py-1.4.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/elasticsearch-py/elasticsearch-py-1.4.0.ebuild b/dev-python/elasticsearch-py/elasticsearch-py-1.4.0.ebuild
new file mode 100644
index 000000000000..3f624070b1f9
--- /dev/null
+++ b/dev-python/elasticsearch-py/elasticsearch-py-1.4.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/elasticsearch-py/elasticsearch-py-1.4.0.ebuild,v 1.1 2015/02/15 06:44:59 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="official Python low-level client for Elasticsearch"
+HOMEPAGE="http://elasticsearch-py.rtfd.org/"
+SRC_URI="https://github.com/elasticsearch/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE=""
+
+DEPEND="dev-python/urllib3[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"