summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-02-24 17:53:32 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-02-24 17:53:32 +0000
commita0e2eb5c1a17243e4fef33e5d47756b6ffe2c75b (patch)
tree9dd021598a80f0d6c8b6931ce903f8db8007a6b1 /dev-python/drpython/drpython-165-r2.ebuild
parentMarking lyx-1.4.4 ppc64 for bug 209465 (diff)
downloadgentoo-2-a0e2eb5c1a17243e4fef33e5d47756b6ffe2c75b.tar.gz
gentoo-2-a0e2eb5c1a17243e4fef33e5d47756b6ffe2c75b.tar.bz2
gentoo-2-a0e2eb5c1a17243e4fef33e5d47756b6ffe2c75b.zip
Added patch to fix broken copy/paste when switching tabs using the keyboard shortcut (bug #210298, thanks to Jon White).
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python/drpython/drpython-165-r2.ebuild')
-rw-r--r--dev-python/drpython/drpython-165-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/drpython/drpython-165-r2.ebuild b/dev-python/drpython/drpython-165-r2.ebuild
new file mode 100644
index 000000000000..e364557580f8
--- /dev/null
+++ b/dev-python/drpython/drpython-165-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/drpython-165-r2.ebuild,v 1.1 2008/02/24 17:53:32 dev-zero Exp $
+
+EAPI="1"
+
+inherit distutils eutils multilib
+
+DESCRIPTION="A powerful cross-platform IDE for Python"
+HOMEPAGE="http://drpython.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P/-}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/wxpython:2.6"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ distutils_src_unpack
+ epatch \
+ "${FILESDIR}/${P}-wxversion.patch" \
+ "${FILESDIR}/${P}-tabswitch.patch"
+}
+
+src_install() {
+ distutils_python_version
+
+ local destdir="/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}"
+ dodir ${destdir}/bitmaps/{16,24}
+ cp -R bitmaps "${D}/${destdir}/" || die "failed to cp bitmaps"
+
+ distutils_src_install
+
+ # Windows-only setup script:
+ rm "${D}/usr/bin/postinst.py"
+
+ make_wrapper drpython "python ${destdir}/drpython_wx26.py"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ elog "See the DrPython homepage for 20+ available plugins:"
+ elog "http://sourceforge.net/project/showfiles.php?group_id=83074"
+}