summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-01 01:35:31 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-01 01:35:31 +0000
commita1899b6d66bff43a4cf282643b1eba29d030e2d2 (patch)
tree70194de38393bbffc5ad1524ba5e2cb68ab0a8a4 /dev-python/dpkt/dpkt-1.7.ebuild
parentDelete older ebuild. (diff)
downloadgentoo-2-a1899b6d66bff43a4cf282643b1eba29d030e2d2.tar.gz
gentoo-2-a1899b6d66bff43a4cf282643b1eba29d030e2d2.tar.bz2
gentoo-2-a1899b6d66bff43a4cf282643b1eba29d030e2d2.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/dpkt/dpkt-1.7.ebuild')
-rw-r--r--dev-python/dpkt/dpkt-1.7.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/dpkt/dpkt-1.7.ebuild b/dev-python/dpkt/dpkt-1.7.ebuild
new file mode 100644
index 000000000000..e4f9ad8dc8d2
--- /dev/null
+++ b/dev-python/dpkt/dpkt-1.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dpkt/dpkt-1.7.ebuild,v 1.1 2010/07/01 01:35:31 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Fast, simple packet creation / parsing, with definitions for the basic TCP/IP protocols."
+HOMEPAGE="http://code.google.com/p/dpkt/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+DOCS="AUTHORS CHANGES HACKING"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" tests/test-perf2.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}