summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-02 02:02:13 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-02 02:02:13 +0000
commitde185ca17ff01294b86c1efefbea74cef916ff48 (patch)
tree05894ec7b4bf704c447ae59a21ac683edcfa27b0 /dev-python/django-evolution
parentFixed dependency on mercurial versions. Removed old (diff)
downloadgentoo-2-de185ca17ff01294b86c1efefbea74cef916ff48.tar.gz
gentoo-2-de185ca17ff01294b86c1efefbea74cef916ff48.tar.bz2
gentoo-2-de185ca17ff01294b86c1efefbea74cef916ff48.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django-evolution')
-rw-r--r--dev-python/django-evolution/ChangeLog7
-rw-r--r--dev-python/django-evolution/django-evolution-0.7.3.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/django-evolution/ChangeLog b/dev-python/django-evolution/ChangeLog
index fca53a984519..a7d523a0c118 100644
--- a/dev-python/django-evolution/ChangeLog
+++ b/dev-python/django-evolution/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/django-evolution
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-evolution/ChangeLog,v 1.12 2014/06/05 03:13:42 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-evolution/ChangeLog,v 1.13 2014/08/02 02:02:13 idella4 Exp $
+
+*django-evolution-0.7.3 (02 Aug 2014)
+
+ 02 Aug 2014; Ian Delaney <idella4@gentoo.org> +django-evolution-0.7.3.ebuild:
+ bump
*django-evolution-0.7.2 (05 Jun 2014)
diff --git a/dev-python/django-evolution/django-evolution-0.7.3.ebuild b/dev-python/django-evolution/django-evolution-0.7.3.ebuild
new file mode 100644
index 000000000000..048bf024fe85
--- /dev/null
+++ b/dev-python/django-evolution/django-evolution-0.7.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-evolution/django-evolution-0.7.3.ebuild,v 1.1 2014/08/02 02:02:13 idella4 Exp $
+
+EAPI=5
+
+# This is NOT py3 compatible
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+RELEASE="0.7"
+
+DESCRIPTION="A Django application that will run cron jobs for other django apps"
+HOMEPAGE="http://code.google.com/p/django-evolution/ http://pypi.python.org/pypi/django_evolution/"
+SRC_URI="http://downloads.reviewboard.org/releases/${PN}/${RELEASE}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+DOCS=( AUTHORS NEWS docs/{evolution.txt,faq.txt} )
+
+python_test() {
+ # http://code.google.com/p/django-evolution/issues/detail?id=135
+ # This is tested, any delay in die subsequent to (implicitly inherited) multiprocessing eclass
+ "${PYTHON}" tests/runtests.py || die
+}