summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-23 20:03:38 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-23 20:03:38 +0000
commit0f6223e2344149e757ecc41470d65995b10ce178 (patch)
treea84f4547774ec08ac898955d9f7c210bb2dfa61a /dev-python/clientcookie
parentDelete older ebuild. (diff)
downloadgentoo-2-0f6223e2344149e757ecc41470d65995b10ce178.tar.gz
gentoo-2-0f6223e2344149e757ecc41470d65995b10ce178.tar.bz2
gentoo-2-0f6223e2344149e757ecc41470d65995b10ce178.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/clientcookie')
-rw-r--r--dev-python/clientcookie/ChangeLog8
-rw-r--r--dev-python/clientcookie/clientcookie-1.3.0.ebuild30
2 files changed, 23 insertions, 15 deletions
diff --git a/dev-python/clientcookie/ChangeLog b/dev-python/clientcookie/ChangeLog
index f438059114f1..ab7a69b622a0 100644
--- a/dev-python/clientcookie/ChangeLog
+++ b/dev-python/clientcookie/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/clientcookie
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/clientcookie/ChangeLog,v 1.18 2009/10/10 12:39:31 grobian Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/clientcookie/ChangeLog,v 1.19 2010/07/23 20:03:38 arfrever Exp $
+
+ 23 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ clientcookie-1.3.0.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
10 Oct 2009; Fabian Groffen <grobian@gentoo.org>
clientcookie-1.3.0.ebuild:
diff --git a/dev-python/clientcookie/clientcookie-1.3.0.ebuild b/dev-python/clientcookie/clientcookie-1.3.0.ebuild
index 1eee58b91c96..9e8fcc442106 100644
--- a/dev-python/clientcookie/clientcookie-1.3.0.ebuild
+++ b/dev-python/clientcookie/clientcookie-1.3.0.ebuild
@@ -1,33 +1,37 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/clientcookie/clientcookie-1.3.0.ebuild,v 1.3 2009/10/10 12:39:31 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/clientcookie/clientcookie-1.3.0.ebuild,v 1.4 2010/07/23 20:03:38 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
MY_P="ClientCookie-${PV}"
+
DESCRIPTION="Python module for handling HTTP cookies on the client side"
-HOMEPAGE="http://wwwsearch.sourceforge.net/ClientCookie/"
+HOMEPAGE="http://wwwsearch.sourceforge.net/ClientCookie/ http://pypi.python.org/pypi/ClientCookie"
SRC_URI="http://wwwsearch.sourceforge.net/ClientCookie/src/${MY_P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
IUSE=""
-S="${WORKDIR}/${MY_P}"
-DOCS="*.txt"
+DEPEND="dev-python/setuptools"
+RDEPEND=""
-src_unpack() {
- unpack ${A}
- cd ${S}
+S="${WORKDIR}/${MY_P}"
- # use distutils instead of setuptools
- sed -e 's/not hasattr(sys, "version_info")/1/' -i setup.py
-}
+DOCS="*.txt"
+PYTHON_MODNAME="ClientCookie"
src_install() {
- # remove to prevent distutils_src_install from installing it
+ # Remove to prevent distutils_src_install() from installing them.
dohtml *.html
- rm README.html*
+ rm -f README.html*
distutils_src_install
}