summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-20 03:54:10 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-20 03:54:10 +0000
commit0e737aec20c8cf3e835cf1e2c51e6b5481590755 (patch)
treee7d58b169b0d28e0823b243160804bf69713251e /dev-python/cherrypy
parentVersion bump. Define subslot based on libopenconnect soname. (diff)
downloadgentoo-2-0e737aec20c8cf3e835cf1e2c51e6b5481590755.tar.gz
gentoo-2-0e737aec20c8cf3e835cf1e2c51e6b5481590755.tar.bz2
gentoo-2-0e737aec20c8cf3e835cf1e2c51e6b5481590755.zip
rm old versions, disused patch from FILESDIR and var from -3.3.0
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/cherrypy')
-rw-r--r--dev-python/cherrypy/ChangeLog8
-rw-r--r--dev-python/cherrypy/cherrypy-2.3.0.ebuild57
-rw-r--r--dev-python/cherrypy/cherrypy-3.2.0.ebuild56
-rw-r--r--dev-python/cherrypy/cherrypy-3.2.1.ebuild54
-rw-r--r--dev-python/cherrypy/cherrypy-3.2.2-r1.ebuild48
-rw-r--r--dev-python/cherrypy/cherrypy-3.2.2.ebuild54
-rw-r--r--dev-python/cherrypy/cherrypy-3.2.5.ebuild48
-rw-r--r--dev-python/cherrypy/cherrypy-3.3.0.ebuild6
-rw-r--r--dev-python/cherrypy/files/cherrypy-3.2.5-issue1234.patch10
9 files changed, 8 insertions, 333 deletions
diff --git a/dev-python/cherrypy/ChangeLog b/dev-python/cherrypy/ChangeLog
index 0c8f26c88a99..68062ec9d53b 100644
--- a/dev-python/cherrypy/ChangeLog
+++ b/dev-python/cherrypy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/cherrypy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/ChangeLog,v 1.69 2014/12/07 12:01:50 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/ChangeLog,v 1.70 2014/12/20 03:54:09 idella4 Exp $
+
+ 20 Dec 2014; Ian Delaney <idella4@gentoo.org> -cherrypy-2.3.0.ebuild,
+ -cherrypy-3.2.0.ebuild, -cherrypy-3.2.1.ebuild, -cherrypy-3.2.2-r1.ebuild,
+ -cherrypy-3.2.2.ebuild, -cherrypy-3.2.5.ebuild,
+ -files/cherrypy-3.2.5-issue1234.patch, cherrypy-3.3.0.ebuild:
+ rm old versions, disused patch from FILESDIR and var from -3.3.0
07 Dec 2014; Agostino Sarubbo <ago@gentoo.org> cherrypy-3.3.0.ebuild:
Stable for ppc, wrt bug #530412
diff --git a/dev-python/cherrypy/cherrypy-2.3.0.ebuild b/dev-python/cherrypy/cherrypy-2.3.0.ebuild
deleted file mode 100644
index 4c903abcdba8..000000000000
--- a/dev-python/cherrypy/cherrypy-2.3.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-2.3.0.ebuild,v 1.4 2010/11/14 21:05:42 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-MY_P="CherryPy-${PV}"
-
-DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
-HOMEPAGE="http://www.cherrypy.org/ http://pypi.python.org/pypi/CherryPy"
-SRC_URI="http://download.cherrypy.org/${PN}/${PV}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-DEPEND="dev-python/setuptools
- test? ( >=dev-python/webtest-1.0 )"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- # Remove test_cache_filter, only works outside of portage
- sed -i \
- -e '/raw_input/d' \
- -e "/'test_cache_filter',/d" \
- cherrypy/test/test.py || die "sed failed"
-
- sed -i \
- -e 's/"cherrypy.tutorial",//' \
- -e "/('cherrypy\/tutorial',/, /),/d" \
- -e 's/distutils.core/setuptools/' \
- setup.py || die "sed failed"
-}
-
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" cherrypy/test/test.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r cherrypy/tutorial
- fi
-}
diff --git a/dev-python/cherrypy/cherrypy-3.2.0.ebuild b/dev-python/cherrypy/cherrypy-3.2.0.ebuild
deleted file mode 100644
index 1b1d9b818b27..000000000000
--- a/dev-python/cherrypy/cherrypy-3.2.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.2.0.ebuild,v 1.6 2011/04/23 18:16:03 armin76 Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-MY_P="CherryPy-${PV}"
-
-DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
-HOMEPAGE="http://www.cherrypy.org/ http://pypi.python.org/pypi/CherryPy"
-SRC_URI="http://download.cherrypy.org/${PN}/${PV}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ia64 ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- distutils_src_prepare
- sed -i \
- -e 's/"cherrypy.tutorial", //' \
- -e "/('cherrypy\/tutorial',/,/),/d" \
- setup.py || die "sed failed"
-}
-
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests -P -s py$(python_get_version --major)/cherrypy/test
- }
- python_execute_function testing
-# python_execute_nosetests -e -P 'build-${PYTHON_ABI}/lib' -- -P -s 'py$(python_get_version --major)/cherrypy/test'
-}
-
-src_install() {
- distutils_src_install
-
- delete_tests() {
- rm -fr "${ED}$(python_get_sitedir)/cherrypy/test"
- }
- python_execute_function -q delete_tests
-
- if use doc; then
- insinto /usr/share/doc/${PF}
- # py2/cherrypy/tutorial and py3/cherrypy/tutorial are identical.
- doins -r py3/cherrypy/tutorial || die "Installation of documentation failed"
- fi
-}
diff --git a/dev-python/cherrypy/cherrypy-3.2.1.ebuild b/dev-python/cherrypy/cherrypy-3.2.1.ebuild
deleted file mode 100644
index a7a2a1c1c300..000000000000
--- a/dev-python/cherrypy/cherrypy-3.2.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.2.1.ebuild,v 1.2 2011/12/28 22:44:07 floppym Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-MY_P="CherryPy-${PV}"
-
-DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
-HOMEPAGE="http://www.cherrypy.org/ http://pypi.python.org/pypi/CherryPy"
-SRC_URI="http://download.cherrypy.org/${PN}/${PV}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- distutils_src_prepare
- sed -i \
- -e 's/"cherrypy.tutorial", //' \
- -e "/('cherrypy\/tutorial',/,/),/d" \
- -e "/LICENSE.txt/d" \
- setup.py || die "sed failed"
-}
-
-src_test() {
- distutils_src_test < /dev/tty
-}
-
-src_install() {
- distutils_src_install
-
- delete_tests() {
- rm -fr "${ED}$(python_get_sitedir)/cherrypy/test"
- }
- python_execute_function -q delete_tests
-
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r cherrypy/tutorial || die "Installation of documentation failed"
- fi
-}
diff --git a/dev-python/cherrypy/cherrypy-3.2.2-r1.ebuild b/dev-python/cherrypy/cherrypy-3.2.2-r1.ebuild
deleted file mode 100644
index 342d3ec27f5a..000000000000
--- a/dev-python/cherrypy/cherrypy-3.2.2-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.2.2-r1.ebuild,v 1.10 2014/03/31 20:48:31 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2} pypy pypy2_0 )
-
-inherit distutils-r1
-
-MY_P="CherryPy-${PV}"
-
-DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
-HOMEPAGE="http://www.cherrypy.org/ http://pypi.python.org/pypi/CherryPy"
-SRC_URI="http://download.cherrypy.org/${PN}/${PV}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ia64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-RDEPEND=""
-S="${WORKDIR}/${MY_P}"
-# Both req'd for test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-DISTUTILS_NO_PARALLEL_BUILD=1
-
-python_prepare_all() {
- sed -e 's:test_file_stream:_&:' -i cherrypy/test/test_static.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # https://bitbucket.org/cherrypy/cherrypy/issue/1308/testsuite-failures-x-5-test_file_stream
- if python_is_python3; then
- sed -e 's:test_HTTP11_pipelining:_&:' -i cherrypy/test/test_conn.py || die
- elif [[ "${EPYTHON}" == "pypy-c2.0" || "${EPYTHON}" == "pypy-c" ]]; then
- einfo "done"
- sed -e 's:testEscapedOutput:_&:' \
- -e 's:testNormalReturn:_&:' \
- -e 's:testTracebacks:_&:' \
- -e 's:testNormalYield:_&:' \
- -i cherrypy/test/test_logging.py || die
- fi
- # This really doesn't sit well with multiprocessing
- nosetests < /dev/tty || die "Testing failed with ${EPYTHON}"
-}
diff --git a/dev-python/cherrypy/cherrypy-3.2.2.ebuild b/dev-python/cherrypy/cherrypy-3.2.2.ebuild
deleted file mode 100644
index 4b34a9871f45..000000000000
--- a/dev-python/cherrypy/cherrypy-3.2.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.2.2.ebuild,v 1.2 2012/07/17 02:07:57 vapier Exp $
-
-EAPI="4"
-PYTHON_DEPEND="*:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-MY_P="CherryPy-${PV}"
-
-DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
-HOMEPAGE="http://www.cherrypy.org/ http://pypi.python.org/pypi/CherryPy"
-SRC_URI="http://download.cherrypy.org/${PN}/${PV}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- distutils_src_prepare
- sed -i \
- -e 's/"cherrypy.tutorial", //' \
- -e "/('cherrypy\/tutorial',/,/),/d" \
- -e "/LICENSE.txt/d" \
- setup.py || die "sed failed"
-}
-
-src_test() {
- distutils_src_test < /dev/tty
-}
-
-src_install() {
- distutils_src_install
-
- delete_tests() {
- rm -fr "${ED}$(python_get_sitedir)/cherrypy/test"
- }
- python_execute_function -q delete_tests
-
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r cherrypy/tutorial
- fi
-}
diff --git a/dev-python/cherrypy/cherrypy-3.2.5.ebuild b/dev-python/cherrypy/cherrypy-3.2.5.ebuild
deleted file mode 100644
index f1e6adcc7660..000000000000
--- a/dev-python/cherrypy/cherrypy-3.2.5.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.2.5.ebuild,v 1.2 2014/04/05 21:07:43 floppym Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2} pypy pypy2_0 )
-
-inherit distutils-r1
-
-MY_P="CherryPy-${PV}"
-
-DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
-HOMEPAGE="http://www.cherrypy.org/ http://pypi.python.org/pypi/CherryPy"
-SRC_URI="mirror://pypi/C/CherryPy/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-RDEPEND=""
-S="${WORKDIR}/${MY_P}"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PATCHES=(
- "${FILESDIR}"/cherrypy-3.2.5-issue1234.patch
-)
-
-python_prepare_all() {
- # Prevent interactive failures (hangs) in the test suite
- sed -i -e "s/interactive = True/interactive = False/" cherrypy/test/webtest.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Failure in test_file_stream
- # https://bitbucket.org/cherrypy/cherrypy/issue/1308/testsuite-failures-x-5-test_file_stream
-
- # This really doesn't sit well with multiprocessing
- nosetests -e test_file_stream < /dev/tty || die "Testing failed with ${EPYTHON}"
-}
-
-src_test() {
- DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
-}
diff --git a/dev-python/cherrypy/cherrypy-3.3.0.ebuild b/dev-python/cherrypy/cherrypy-3.3.0.ebuild
index 62011fe63e75..1fa7ba7d7f1f 100644
--- a/dev-python/cherrypy/cherrypy-3.3.0.ebuild
+++ b/dev-python/cherrypy/cherrypy-3.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.3.0.ebuild,v 1.8 2014/12/07 12:01:50 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.3.0.ebuild,v 1.9 2014/12/20 03:54:09 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
@@ -51,7 +51,3 @@ python_test() {
nosetests "${exclude[@]}" < /dev/tty || die "Testing failed with ${EPYTHON}"
fi
}
-
-src_test() {
- DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
-}
diff --git a/dev-python/cherrypy/files/cherrypy-3.2.5-issue1234.patch b/dev-python/cherrypy/files/cherrypy-3.2.5-issue1234.patch
deleted file mode 100644
index fd76c5e9cb36..000000000000
--- a/dev-python/cherrypy/files/cherrypy-3.2.5-issue1234.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-https://bitbucket.org/cherrypy/cherrypy/issue/1234
-
---- cherrypy/test/test_tools.py
-+++ cherrypy/test/test_tools.py
-@@ -407,4 +407,4 @@
- sa = cherrypy.lib.cptools.SessionAuth()
- res = sa.login_screen(None, username=unicodestr('nobody'),
- password=unicodestr('anypass'))
-- self.assertIsInstance(res, bytestr)
-+ self.assertTrue(isinstance(res, bytestr))