summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-08 13:44:35 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-08 13:44:35 +0000
commit06136df8f50c2862f342ca6bf4ea22e3accb148e (patch)
treef039d0af2898e8fef59301ed1a7553d8cb072d7e /dev-python/cheetah
parentVersion bump. (diff)
downloadgentoo-2-06136df8f50c2862f342ca6bf4ea22e3accb148e.tar.gz
gentoo-2-06136df8f50c2862f342ca6bf4ea22e3accb148e.tar.bz2
gentoo-2-06136df8f50c2862f342ca6bf4ea22e3accb148e.zip
Version bump.
(Portage version: 15325-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/cheetah')
-rw-r--r--dev-python/cheetah/ChangeLog8
-rw-r--r--dev-python/cheetah/cheetah-2.4.2.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-python/cheetah/ChangeLog b/dev-python/cheetah/ChangeLog
index 8389698f1af5..7174cdc33e2c 100644
--- a/dev-python/cheetah/ChangeLog
+++ b/dev-python/cheetah/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/cheetah
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cheetah/ChangeLog,v 1.60 2010/02/07 19:52:17 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cheetah/ChangeLog,v 1.61 2010/02/08 13:44:35 arfrever Exp $
+
+*cheetah-2.4.2 (08 Feb 2010)
+
+ 08 Feb 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +cheetah-2.4.2.ebuild:
+ Version bump.
07 Feb 2010; Markus Meier <maekke@gentoo.org> cheetah-2.4.1.ebuild:
x86 stable, bug #301951
diff --git a/dev-python/cheetah/cheetah-2.4.2.ebuild b/dev-python/cheetah/cheetah-2.4.2.ebuild
new file mode 100644
index 000000000000..9e4e481d9405
--- /dev/null
+++ b/dev-python/cheetah/cheetah-2.4.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cheetah/cheetah-2.4.2.ebuild,v 1.1 2010/02/08 13:44:35 arfrever Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="Cheetah"
+MY_P="${MY_PN}-${PV/_}"
+
+DESCRIPTION="Python-powered template engine and code generator."
+HOMEPAGE="http://www.cheetahtemplate.org/ http://rtyler.github.com/cheetah/ http://pypi.python.org/pypi/Cheetah"
+SRC_URI="http://pypi.python.org/packages/source/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="PSF-2.2"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+SLOT="0"
+
+RDEPEND="dev-python/markdown"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="Cheetah"
+DOCS="CHANGES README.markdown TODO"
+
+src_prepare() {
+ # Disable broken tests.
+ sed \
+ -e "/Unicode/d" \
+ -e "s/if not sys.platform.startswith('java'):/if False:/" \
+ -e "/results =/a\\ sys.exit(not results.wasSuccessful())" \
+ -i cheetah/Tests/Test.py || die "sed failed"
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" cheetah/Tests/Test.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ [[ -z "${ED}" ]] && local ED="${D}"
+ distutils_src_install
+ rm -fr "${ED}"usr/lib*/python*/site-packages/Cheetah/Tests
+}