summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-29 08:50:39 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-29 08:50:39 +0000
commitc31c76ab90eae2b99a656942b03c8603ed053802 (patch)
tree521248e4f7d73f8975a6694d542c818b0b731d22 /dev-python/chameleon
parentAdd offline patch to fix bug #440062. Make sure we use newest en_dict. Add ep... (diff)
downloadgentoo-2-c31c76ab90eae2b99a656942b03c8603ed053802.tar.gz
gentoo-2-c31c76ab90eae2b99a656942b03c8603ed053802.tar.bz2
gentoo-2-c31c76ab90eae2b99a656942b03c8603ed053802.zip
Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/chameleon')
-rw-r--r--dev-python/chameleon/ChangeLog7
-rw-r--r--dev-python/chameleon/chameleon-2.10.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-python/chameleon/ChangeLog b/dev-python/chameleon/ChangeLog
index a2f02b1f2d0c..abb7fa25bbf7 100644
--- a/dev-python/chameleon/ChangeLog
+++ b/dev-python/chameleon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/chameleon
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/ChangeLog,v 1.15 2012/06/28 06:14:36 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/ChangeLog,v 1.16 2012/10/29 08:50:39 patrick Exp $
+
+*chameleon-2.10 (29 Oct 2012)
+
+ 29 Oct 2012; Patrick Lauer <patrick@gentoo.org> +chameleon-2.10.ebuild:
+ Bump
*chameleon-2.9.2 (28 Jun 2012)
diff --git a/dev-python/chameleon/chameleon-2.10.ebuild b/dev-python/chameleon/chameleon-2.10.ebuild
new file mode 100644
index 000000000000..63aa5d958b9e
--- /dev/null
+++ b/dev-python/chameleon/chameleon-2.10.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/chameleon/chameleon-2.10.ebuild,v 1.1 2012/10/29 08:50:39 patrick Exp $
+
+EAPI=3
+
+SUPPORT_PYTHON_ABIS=1
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+MY_PN="Chameleon"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Fast HTML/XML template compiler for Python"
+HOMEPAGE="http://chameleon.repoze.org http://pypi.python.org/pypi/Chameleon"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ emake html || die "make html failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ delete_tests_and_incompatible_modules() {
+ rm -fr "${ED}$(python_get_sitedir)/chameleon/tests"
+
+ if [[ "$(python_get_version -l --major)" == "3" ]]; then
+ rm -f "${ED}$(python_get_sitedir)/chameleon/"{benchmark.py,py25.py}
+ fi
+
+ if [[ $(python_get_version -l) == "2.5" ]]; then
+ echo "raise SyntaxError" > \
+ "${ED}$(python_get_sitedir -b)/chameleon/py26.py"
+ fi
+ }
+ python_execute_function -q delete_tests_and_incompatible_modules
+
+ if use doc; then
+ pushd _build/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static
+ popd > /dev/null
+ fi
+}