summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-12-06 06:16:18 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-12-06 06:16:18 +0000
commit1a4c4e5286a289b72fb2da6999b32e2e76bbd907 (patch)
treef82bc9afdecbe70858bb8b77b2cd0f4675d74d03 /dev-python/cffi
parentBump (diff)
downloadgentoo-2-1a4c4e5286a289b72fb2da6999b32e2e76bbd907.tar.gz
gentoo-2-1a4c4e5286a289b72fb2da6999b32e2e76bbd907.tar.bz2
gentoo-2-1a4c4e5286a289b72fb2da6999b32e2e76bbd907.zip
Bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/cffi')
-rw-r--r--dev-python/cffi/ChangeLog7
-rw-r--r--dev-python/cffi/cffi-0.8.1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/cffi/ChangeLog b/dev-python/cffi/ChangeLog
index c84cb9e257d3..c26d7907118b 100644
--- a/dev-python/cffi/ChangeLog
+++ b/dev-python/cffi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cffi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/ChangeLog,v 1.17 2013/11/30 04:04:46 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/ChangeLog,v 1.18 2013/12/06 06:16:18 patrick Exp $
+
+*cffi-0.8.1 (06 Dec 2013)
+
+ 06 Dec 2013; Patrick Lauer <patrick@gentoo.org> +cffi-0.8.1.ebuild:
+ Bump
30 Nov 2013; Mike Gilbert <floppym@gentoo.org> cffi-0.7.2.ebuild,
cffi-0.8.ebuild:
diff --git a/dev-python/cffi/cffi-0.8.1.ebuild b/dev-python/cffi/cffi-0.8.1.ebuild
new file mode 100644
index 000000000000..2223fb63ef44
--- /dev/null
+++ b/dev-python/cffi/cffi-0.8.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.8.1.ebuild,v 1.1 2013/12/06 06:16:18 patrick Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Foreign Function Interface for Python calling C code."
+HOMEPAGE="http://cffi.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc test"
+
+RDEPEND="virtual/libffi
+ dev-python/pycparser[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/hgdistver"
+DEPEND="$REDEPEND
+ test? ( dev-python/virtualenv )"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ py.test -x -v --ignore testing/test_zintegration.py c/ testing/
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dohtml -r doc/build/
+}