summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-07-16 08:56:47 +0000
committerIan Delaney <idella4@gentoo.org>2014-07-16 08:56:47 +0000
commitffb68228938930560b33fb0ae4221075fabc97b9 (patch)
tree62b1e41eb70e687b15c73f9224e2d24a4d8ba8b5 /dev-python/celery
parentbump, remove old (diff)
downloadgentoo-2-ffb68228938930560b33fb0ae4221075fabc97b9.tar.gz
gentoo-2-ffb68228938930560b33fb0ae4221075fabc97b9.tar.bz2
gentoo-2-ffb68228938930560b33fb0ae4221075fabc97b9.zip
remove old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/celery')
-rw-r--r--dev-python/celery/ChangeLog5
-rw-r--r--dev-python/celery/celery-3.1.10.ebuild72
2 files changed, 4 insertions, 73 deletions
diff --git a/dev-python/celery/ChangeLog b/dev-python/celery/ChangeLog
index 54a0246c41d4..88b0d4d95690 100644
--- a/dev-python/celery/ChangeLog
+++ b/dev-python/celery/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/celery
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/ChangeLog,v 1.37 2014/07/06 12:40:49 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/ChangeLog,v 1.38 2014/07/16 08:56:47 idella4 Exp $
+
+ 16 Jul 2014; Ian Delaney <idella4@gentoo.org> -celery-3.1.10.ebuild:
+ remove old
06 Jul 2014; Michał Górny <mgorny@gentoo.org> celery-3.1.10.ebuild,
celery-3.1.11.ebuild, celery-3.1.12.ebuild:
diff --git a/dev-python/celery/celery-3.1.10.ebuild b/dev-python/celery/celery-3.1.10.ebuild
deleted file mode 100644
index 408267f2ba1a..000000000000
--- a/dev-python/celery/celery-3.1.10.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/celery-3.1.10.ebuild,v 1.4 2014/07/06 12:40:49 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Celery is an open source asynchronous task queue/job queue based on distributed message passing."
-HOMEPAGE="http://celeryproject.org/ http://pypi.python.org/pypi/celery"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples redis test"
-
-PY2_USEDEP=$(python_gen_usedep python2_7)
-RDEPEND="<dev-python/kombu-4
- >=dev-python/kombu-3.0.14[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
- >=dev-python/anyjson-0.3.3[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- >=dev-python/billiard-3.3.0.14[${PYTHON_USEDEP}]
- <dev-python/billiard-3.4[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/gevent[${PY2_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/nose-cover3[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/pymongo[${PYTHON_USEDEP}]
- redis? ( dev-python/redis-py[${PYTHON_USEDEP}]
- >=dev-db/redis-2.8.0 )
- )
- doc? (
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/celery-docs.patch
- "${FILESDIR}"/${P}-test.patch)
-
-python_compile_all() {
- if use doc; then
- mkdir docs/.build || die
- emake -C docs html
- fi
-}
-
-python_test() {
- # https://github.com/celery/celery/issues/1964
- nosetests -e test_cleanup || die "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- # Main celeryd init.d and conf.d
- newinitd "${FILESDIR}/celery.initd-r1" celery
- newconfd "${FILESDIR}/celery.confd-r1" celery
-
- use examples && local EXAMPLES=( examples/. )
-
- use doc && local HTML_DOCS=( docs/.build/html/. )
-
- distutils-r1_python_install_all
-}