summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-09-26 15:26:59 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-09-26 15:26:59 +0000
commit726d8d32e84c18301e2cc5df83ace724628bd3f1 (patch)
tree3b901f13511ef634012150fc82f28a55b74c7a8c /dev-python/autopep8
parentppc/ppc64 stable wrt #404433 (diff)
downloadgentoo-2-726d8d32e84c18301e2cc5df83ace724628bd3f1.tar.gz
gentoo-2-726d8d32e84c18301e2cc5df83ace724628bd3f1.tar.bz2
gentoo-2-726d8d32e84c18301e2cc5df83ace724628bd3f1.zip
Version bump
(Portage version: 2.2.0_alpha131/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/ChangeLog7
-rw-r--r--dev-python/autopep8/autopep8-0.8.1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/autopep8/ChangeLog b/dev-python/autopep8/ChangeLog
index c883941ea1ef..6ce4b633c144 100644
--- a/dev-python/autopep8/ChangeLog
+++ b/dev-python/autopep8/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/autopep8
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/ChangeLog,v 1.18 2012/09/07 09:33:12 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/ChangeLog,v 1.19 2012/09/26 15:26:59 xarthisius Exp $
+
+*autopep8-0.8.1 (26 Sep 2012)
+
+ 26 Sep 2012; Kacper Kowalik <xarthisius@gentoo.org> +autopep8-0.8.1.ebuild:
+ Version bump
*autopep8-0.8 (07 Sep 2012)
diff --git a/dev-python/autopep8/autopep8-0.8.1.ebuild b/dev-python/autopep8/autopep8-0.8.1.ebuild
new file mode 100644
index 000000000000..f8e582859bd2
--- /dev/null
+++ b/dev-python/autopep8/autopep8-0.8.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-0.8.1.ebuild,v 1.1 2012/09/26 15:26:59 xarthisius Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="*:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5"
+
+inherit distutils vcs-snapshot
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 http://pypi.python.org/pypi/autopep8"
+SRC_URI="https://github.com/hhatto/${PN}/tarball/ver${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-python/pep8-1.3
+ dev-python/setuptools"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME=${PN}.py
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/test_${PN}.py
+ }
+ python_execute_function testing
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ ewarn "Since this version of autopep depends on >=dev-python/pep8-1.3"
+ ewarn "it is affected by https://github.com/jcrocholl/pep8/issues/45"
+ ewarn "(indentation checks inside triple-quotes)."
+ ewarn "If you do not want to be affected by this, then add the"
+ ewarn "following lines to your local package.mask:"
+ ewarn " >=dev-python/pep8-1.3"
+ ewarn " >=dev-python/autopep8-0.6"
+}