summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-26 17:26:25 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-26 17:26:25 +0000
commitb2580874d3954be03b2e9c84e9d12c6f0a8f571d (patch)
tree4492783057586130c00b9289f0a5569cbcbeb202 /dev-python/astng
parentConvert font deps to virtual/ttf-fonts wrt bug 282754. (diff)
downloadgentoo-2-b2580874d3954be03b2e9c84e9d12c6f0a8f571d.tar.gz
gentoo-2-b2580874d3954be03b2e9c84e9d12c6f0a8f571d.tar.bz2
gentoo-2-b2580874d3954be03b2e9c84e9d12c6f0a8f571d.zip
Version bump (bug #311323).
(Portage version: 15841-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/astng')
-rw-r--r--dev-python/astng/ChangeLog8
-rw-r--r--dev-python/astng/astng-0.20.0.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-python/astng/ChangeLog b/dev-python/astng/ChangeLog
index 87b82d0af9f9..231b9348a2e4 100644
--- a/dev-python/astng/ChangeLog
+++ b/dev-python/astng/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/astng
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/ChangeLog,v 1.31 2010/02/27 20:45:52 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/ChangeLog,v 1.32 2010/03/26 17:26:25 arfrever Exp $
+
+*astng-0.20.0 (26 Mar 2010)
+
+ 26 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +astng-0.20.0.ebuild:
+ Version bump (bug #311323).
27 Feb 2010; Fabian Groffen <grobian@gentoo.org> astng-0.19.3-r1.ebuild:
Marked ~x64-macos, thanks Ramon van Alteren in bug #306705
diff --git a/dev-python/astng/astng-0.20.0.ebuild b/dev-python/astng/astng-0.20.0.ebuild
new file mode 100644
index 000000000000..889dc36981c9
--- /dev/null
+++ b/dev-python/astng/astng-0.20.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.20.0.ebuild,v 1.1 2010/03/26 17:26:25 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Abstract Syntax Tree New Generation for logilab packages"
+HOMEPAGE="http://www.logilab.org/projects/astng/ http://pypi.python.org/pypi/logilab-astng"
+SRC_URI="ftp://ftp.logilab.org/pub/astng/logilab-${P}.tar.gz http://pypi.python.org/packages/source/l/logilab-astng/logilab-${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND=">=dev-python/logilab-common-0.39.0"
+DEPEND="${RDEPEND}
+ test? ( >=dev-python/egenix-mx-base-3.0.0 )"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/logilab-${P}"
+
+PYTHON_MODNAME="logilab/astng"
+
+src_test() {
+ testing() {
+ local sdir="${T}/test/$(python_get_sitedir)"
+
+ # This is a hack to make tests work without installing to the live
+ # filesystem. We copy part of the logilab site-packages to a temporary
+ # dir, install there, and run from there.
+ mkdir -p "${sdir}/logilab" || die
+ cp -r "$(python_get_sitedir)/logilab/common" "${sdir}/logilab" || die "copying logilab-common failed!"
+
+ "$(PYTHON)" setup.py install --root="${T}/test" || die "test copy failed"
+
+ # Pytest picks up tests relative to the current dir, so cd in.
+ pushd "${sdir}/logilab/astng" > /dev/null || die
+ PYTHONPATH="${sdir}" pytest -v || die "tests failed"
+ popd > /dev/null
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ deletion_of_unneeded_files() {
+ local sdir="${ED}$(python_get_sitedir)/logilab"
+
+ # we need to remove this file because it collides with the one
+ # from logilab-common (which we depend on).
+ # Bug 111970 and bug 223025
+ rm -f "${sdir}/__init__.py" || die
+
+ # Remove unittests since they're just needed during build-time
+ rm -fr "${sdir}/astng/test" || die
+ }
+ python_execute_function --action-message 'Deletion of unneeded files with Python ${PYTHON_ABI}' deletion_of_unneeded_files
+}