summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-08-11 21:09:56 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-08-11 21:09:56 +0000
commite2afd03c0bbf192a9608557de934645a71a99bdd (patch)
tree30ed842a93ee8fc99ef70119447ef03045729fc7 /dev-python/PyQt
parentbump to take in a patch for sip 4.7 compatibility (diff)
downloadgentoo-2-e2afd03c0bbf192a9608557de934645a71a99bdd.tar.gz
gentoo-2-e2afd03c0bbf192a9608557de934645a71a99bdd.tar.bz2
gentoo-2-e2afd03c0bbf192a9608557de934645a71a99bdd.zip
version bump
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-python/PyQt')
-rw-r--r--dev-python/PyQt/ChangeLog7
-rw-r--r--dev-python/PyQt/PyQt-3.17.2.ebuild4
-rw-r--r--dev-python/PyQt/PyQt-3.17.3.ebuild56
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.17.33
4 files changed, 67 insertions, 3 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index f73f4d1bfbe6..60c4ac57fb86 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/PyQt
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.91 2007/06/24 19:23:36 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.92 2007/08/11 21:09:56 caleb Exp $
+
+*PyQt-3.17.3 (11 Aug 2007)
+
+ 11 Aug 2007; Caleb Tennis <caleb@gentoo.org> +PyQt-3.17.3.ebuild:
+ version bump
24 Jun 2007; Tiziano Müller <dev-zero@gentoo.org> PyQt-3.14.1-r1.ebuild,
PyQt-3.14.1-r2.ebuild, PyQt-3.17.ebuild, PyQt-3.17.2.ebuild:
diff --git a/dev-python/PyQt/PyQt-3.17.2.ebuild b/dev-python/PyQt/PyQt-3.17.2.ebuild
index c5044c38af7f..391226a74f4e 100644
--- a/dev-python/PyQt/PyQt-3.17.2.ebuild
+++ b/dev-python/PyQt/PyQt-3.17.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.17.2.ebuild,v 1.4 2007/07/11 06:19:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.17.2.ebuild,v 1.5 2007/08/11 21:09:56 caleb Exp $
inherit distutils
@@ -19,7 +19,7 @@ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="debug doc examples"
RDEPEND="=x11-libs/qt-3*
- >=dev-python/sip-4.6
+ ~dev-python/sip-4.6
dev-python/qscintilla"
DEPEND="${RDEPEND}
sys-devel/libtool"
diff --git a/dev-python/PyQt/PyQt-3.17.3.ebuild b/dev-python/PyQt/PyQt-3.17.3.ebuild
new file mode 100644
index 000000000000..aea51df5f95d
--- /dev/null
+++ b/dev-python/PyQt/PyQt-3.17.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.17.3.ebuild,v 1.1 2007/08/11 21:09:56 caleb Exp $
+
+inherit distutils
+
+MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PyQt is a set of Python bindings for the Qt toolkit."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+#SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+SRC_URI="http://www.riverbankcomputing.com/Downloads/PyQt3/GPL/${MY_P}.tar.gz"
+#SRC_URI="http://www.riverbankcomputing.com/Downloads/Snapshots/PyQt3/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples"
+
+RDEPEND="=x11-libs/qt-3*
+ >=dev-python/sip-4.7
+ dev-python/qscintilla"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s: check_license():# check_license():" ${S}/configure.py
+}
+
+src_compile() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages \
+ -b /usr/bin \
+ -v /usr/share/sip \
+ -n /usr/include \
+ -o /usr/$(get_libdir) \
+ -w -y qt-mt"
+ use debug && myconf="${myconf} -u"
+
+ python configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
+ use doc && dohtml doc/PyQt.html
+ if use examples ; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r examples3/* ${D}/usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/PyQt/files/digest-PyQt-3.17.3 b/dev-python/PyQt/files/digest-PyQt-3.17.3
new file mode 100644
index 000000000000..2acf93f5c08b
--- /dev/null
+++ b/dev-python/PyQt/files/digest-PyQt-3.17.3
@@ -0,0 +1,3 @@
+MD5 7a9eb21bb978e7c5df0cf8367b401adb PyQt-x11-gpl-3.17.3.tar.gz 803875
+RMD160 c8faed518146b5aacb45b49927f6f5d88b9f4da0 PyQt-x11-gpl-3.17.3.tar.gz 803875
+SHA256 a6431ac734e19581a7a0ab8b796f1779f758735270f949079b25b3c6ecd19214 PyQt-x11-gpl-3.17.3.tar.gz 803875