summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-07-31 07:09:45 +0000
committerAlex Alexander <wired@gentoo.org>2009-07-31 07:09:45 +0000
commitbb62c6a207dfa8ba74fa1fbbc9bfd94b77b27d75 (patch)
tree1378c9c1f2450f964175f42e52f89fd73e3a4ee0 /dev-python/PyQt4
parentsip version bump (diff)
downloadgentoo-2-bb62c6a207dfa8ba74fa1fbbc9bfd94b77b27d75.tar.gz
gentoo-2-bb62c6a207dfa8ba74fa1fbbc9bfd94b77b27d75.tar.bz2
gentoo-2-bb62c6a207dfa8ba74fa1fbbc9bfd94b77b27d75.zip
PyQt4 version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/PyQt4')
-rw-r--r--dev-python/PyQt4/ChangeLog7
-rw-r--r--dev-python/PyQt4/PyQt4-4.5.4.ebuild120
2 files changed, 126 insertions, 1 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index 393c6d52199a..117514400b45 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.74 2009/07/27 17:25:05 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.75 2009/07/31 07:09:45 wired Exp $
+
+*PyQt4-4.5.4 (31 Jul 2009)
+
+ 31 Jul 2009; Alex Alexander <wired@gentoo.org> +PyQt4-4.5.4.ebuild:
+ version bump
27 Jul 2009; nixnut <nixnut@gentoo.org> PyQt4-4.4.4-r5.ebuild:
ppc stable #276852
diff --git a/dev-python/PyQt4/PyQt4-4.5.4.ebuild b/dev-python/PyQt4/PyQt4-4.5.4.ebuild
new file mode 100644
index 000000000000..e34e4f4f1695
--- /dev/null
+++ b/dev-python/PyQt4/PyQt4-4.5.4.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.5.4.ebuild,v 1.1 2009/07/31 07:09:45 wired Exp $
+
+EAPI="2"
+
+inherit distutils python qt4
+
+MY_P=PyQt-x11-gpl-${PV}
+QTVER="4.5.1"
+
+DESCRIPTION="A set of Python bindings for the Qt toolkit"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 GPL-3 )"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="X assistant +dbus debug doc examples kde opengl phonon sql svg webkit xmlpatterns"
+
+DEPEND=">=dev-python/sip-4.8.2
+ >=x11-libs/qt-core-${QTVER}:4
+ >=x11-libs/qt-script-${QTVER}:4
+ >=x11-libs/qt-test-${QTVER}:4
+ X? ( >=x11-libs/qt-gui-${QTVER}:4[dbus?] )
+ assistant? ( >=x11-libs/qt-assistant-${QTVER}:4 )
+ dbus? (
+ >=dev-python/dbus-python-0.80
+ >=x11-libs/qt-dbus-${QTVER}:4
+ )
+ opengl? ( >=x11-libs/qt-opengl-${QTVER}:4 )
+ phonon? (
+ !kde? ( || ( >=x11-libs/qt-phonon-${QTVER}:4 media-sound/phonon ) )
+ kde? ( media-sound/phonon )
+ )
+ sql? ( >=x11-libs/qt-sql-${QTVER}:4 )
+ svg? ( >=x11-libs/qt-svg-${QTVER}:4 )
+ webkit? ( >=x11-libs/qt-webkit-${QTVER}:4 )
+ xmlpatterns? ( >=x11-libs/qt-xmlpatterns-${QTVER}:4 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/configure.py.patch"
+)
+
+pyqt4_use_enable() {
+ use $1 && echo "--enable=${2:-$1}"
+}
+
+src_prepare() {
+ if ! use dbus; then
+ sed -i -e 's,^\([[:blank:]]\+\)check_dbus(),\1pass,' \
+ "${S}"/configure.py || die
+ fi
+ qt4_src_prepare
+
+ # Remove this code after removing Python 2 from the tree.
+ python_version
+ if [[ "${PYVER:0:1}" == "3" ]]; then
+ rm -fr pyuic/uic/port_v2
+ else
+ rm -fr pyuic/uic/port_v3
+ fi
+}
+
+src_configure() {
+ distutils_python_version
+
+ local myconf="${python} configure.py
+ --confirm-license
+ --bindir=/usr/bin
+ --destdir=$(python_get_sitedir)
+ --sipdir=/usr/share/sip
+ $(use debug && echo '--debug')
+ --enable=QtCore
+ --enable=QtNetwork
+ --enable=QtScript
+ --enable=QtTest
+ --enable=QtXml
+ $(pyqt4_use_enable X QtGui)
+ $(pyqt4_use_enable X QtDesigner)
+ $(pyqt4_use_enable assistant QtAssistant)
+ $(pyqt4_use_enable assistant QtHelp)
+ $(pyqt4_use_enable opengl QtOpenGL)
+ $(pyqt4_use_enable phonon)
+ $(pyqt4_use_enable sql QtSql)
+ $(pyqt4_use_enable svg QtSvg)
+ $(pyqt4_use_enable webkit QtWebKit)
+ $(pyqt4_use_enable xmlpatterns QtXmlPatterns)"
+ echo ${myconf}
+ ${myconf} || die "configuration failed"
+
+ # Fix insecure runpath
+ if use X ; then
+ for pkg in QtDesigner QtGui QtCore; do
+ sed -i -e "/^LFLAGS/s:-Wl,-rpath,${S}/qpy/${pkg}::" \
+ "${S}"/${pkg}/Makefile || die "failed to fix rpath issues"
+ done
+ fi
+}
+
+src_install() {
+ python_need_rebuild
+ # INSTALL_ROOT is needed for the QtDesigner module,
+ # the other Makefiles use DESTDIR.
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install || die "installation failed"
+
+ dodoc ChangeLog NEWS THANKS || die
+
+ if use doc; then
+ dohtml -r doc/html/* || die
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+ fi
+}