summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2014-06-03 10:16:58 +0000
committerOle Markus With <olemarkus@gentoo.org>2014-06-03 10:16:58 +0000
commit1810967929fa5db2d4d7d8d615998f432158a13a (patch)
tree0b598af52bfcacabfa8f2029a735bc7ef2e5e05b /dev-php
parentStable for amd64 wrt bug #508140 (diff)
downloadgentoo-2-1810967929fa5db2d4d7d8d615998f432158a13a.tar.gz
gentoo-2-1810967929fa5db2d4d7d8d615998f432158a13a.tar.bz2
gentoo-2-1810967929fa5db2d4d7d8d615998f432158a13a.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C4A92BF5)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-http/ChangeLog9
-rw-r--r--dev-php/pecl-http/pecl-http-1.7.6.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/dev-php/pecl-http/ChangeLog b/dev-php/pecl-http/ChangeLog
index b028dc5943ad..74c8738737ba 100644
--- a/dev-php/pecl-http/ChangeLog
+++ b/dev-php/pecl-http/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/pecl-http
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-http/ChangeLog,v 1.14 2013/08/07 13:25:13 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-http/ChangeLog,v 1.15 2014/06/03 10:16:58 olemarkus Exp $
+
+*pecl-http-1.7.6 (03 Jun 2014)
+
+ 03 Jun 2014; Ole Markus With <olemarkus@gentoo.org> +pecl-http-1.7.6.ebuild:
+ Version bump
07 Aug 2013; Agostino Sarubbo <ago@gentoo.org> pecl-http-1.7.5.ebuild:
Stable for x86, wrt bug #470442
diff --git a/dev-php/pecl-http/pecl-http-1.7.6.ebuild b/dev-php/pecl-http/pecl-http-1.7.6.ebuild
new file mode 100644
index 000000000000..84429d32a0d4
--- /dev/null
+++ b/dev-php/pecl-http/pecl-http-1.7.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-http/pecl-http-1.7.6.ebuild,v 1.1 2014/06/03 10:16:58 olemarkus Exp $
+
+EAPI="5"
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="docs/examples/tutorial.txt ThanksTo.txt KnownIssues.txt"
+
+USE_PHP="php5-3 php5-4"
+
+inherit php-ext-pecl-r2 php-ext-source-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP."
+LICENSE="BSD-2 MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="net-misc/curl
+ sys-libs/zlib
+ dev-libs/libevent
+ dev-lang/php[hash,session,iconv]
+ "
+RDEPEND="${DEPEND}"
+
+my_conf="--enable-http \
+ --with-http-curl-requests \
+ --with-http-zlib-compression \
+ --with-http-curl-libevent \
+ --with-http-magic-mime"
+
+src_install() {
+ php-ext-pecl-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "http.etag.mode" "MD5"
+ php-ext-source-r2_addtoinifiles "http.force_exit" "1"
+ php-ext-source-r2_addtoinifiles "http.log.allowed_methods" ""
+ php-ext-source-r2_addtoinifiles "http.log.cache" ""
+ php-ext-source-r2_addtoinifiles "http.log.composite" ""
+ php-ext-source-r2_addtoinifiles "http.log.not_found" ""
+ php-ext-source-r2_addtoinifiles "http.log.redirect" ""
+ php-ext-source-r2_addtoinifiles "http.only_exceptions" "0"
+ php-ext-source-r2_addtoinifiles "http.persistent.handles.ident" "GLOBAL"
+ php-ext-source-r2_addtoinifiles "http.persistent.handles.limit" "-1"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.connect" "0"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.cookie" "0"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.dns" "1"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.ssl" "0"
+ php-ext-source-r2_addtoinifiles "http.request.methods.allowed" ""
+ php-ext-source-r2_addtoinifiles "http.request.methods.custom" ""
+ php-ext-source-r2_addtoinifiles "http.send.inflate.start_auto" "0"
+ php-ext-source-r2_addtoinifiles "http.send.inflate.start_flags" "0"
+ php-ext-source-r2_addtoinifiles "http.send.deflate.start_auto" "0"
+ php-ext-source-r2_addtoinifiles "http.send.deflate.start_flags" "0"
+ php-ext-source-r2_addtoinifiles "http.send.not_found_404" "1"
+}