summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-11-04 16:00:47 +0000
committerMatti Bickel <mabi@gentoo.org>2010-11-04 16:00:47 +0000
commitb111d550a2d444fcd428fc2a9020dee728c3948b (patch)
tree969c592e1f5b0360823852357ff51904439f5dc6 /dev-php5
parentVersion bump. (diff)
downloadgentoo-2-b111d550a2d444fcd428fc2a9020dee728c3948b.tar.gz
gentoo-2-b111d550a2d444fcd428fc2a9020dee728c3948b.tar.bz2
gentoo-2-b111d550a2d444fcd428fc2a9020dee728c3948b.zip
add version supporting minor version slotting, version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/pecl-ssh2/ChangeLog9
-rw-r--r--dev-php5/pecl-ssh2/pecl-ssh2-0.11.2-r1.ebuild (renamed from dev-php5/pecl-ssh2/pecl-ssh2-0.11.0.ebuild)12
-rw-r--r--dev-php5/pecl-ssh2/pecl-ssh2-0.11.2.ebuild19
3 files changed, 33 insertions, 7 deletions
diff --git a/dev-php5/pecl-ssh2/ChangeLog b/dev-php5/pecl-ssh2/ChangeLog
index 74c3b56286f1..023da93ef25d 100644
--- a/dev-php5/pecl-ssh2/ChangeLog
+++ b/dev-php5/pecl-ssh2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-php5/pecl-ssh2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-ssh2/ChangeLog,v 1.7 2010/10/14 23:30:59 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-ssh2/ChangeLog,v 1.8 2010/11/04 16:00:47 mabi Exp $
+
+*pecl-ssh2-0.11.2-r1 (04 Nov 2010)
+*pecl-ssh2-0.11.2 (04 Nov 2010)
+
+ 04 Nov 2010; Matti Bickel <mabi@gentoo.org> -pecl-ssh2-0.11.0.ebuild,
+ +pecl-ssh2-0.11.2.ebuild, +pecl-ssh2-0.11.2-r1.ebuild:
+ add version supporting minor version slotting, version bump
14 Oct 2010; Markos Chandras <hwoarang@gentoo.org>
pecl-ssh2-0.11.0-r1.ebuild:
diff --git a/dev-php5/pecl-ssh2/pecl-ssh2-0.11.0.ebuild b/dev-php5/pecl-ssh2/pecl-ssh2-0.11.2-r1.ebuild
index e8d2c2277b2f..25feb537c708 100644
--- a/dev-php5/pecl-ssh2/pecl-ssh2-0.11.0.ebuild
+++ b/dev-php5/pecl-ssh2/pecl-ssh2-0.11.2-r1.ebuild
@@ -1,20 +1,20 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-ssh2/pecl-ssh2-0.11.0.ebuild,v 1.4 2009/12/27 23:19:42 hoffie Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-ssh2/pecl-ssh2-0.11.2-r1.ebuild,v 1.1 2010/11/04 16:00:47 mabi Exp $
+
+EAPI=3
PHP_EXT_NAME="ssh2"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
DOCS="README ChangeLog"
-inherit php-ext-pecl-r1
+inherit php-ext-pecl-r2
DESCRIPTION="Provides bindings to the functions of libssh2 which implements the SSH2 protocol."
LICENSE="PHP-3"
SLOT="0"
IUSE=""
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
DEPEND=">=net-libs/libssh2-0.18"
RDEPEND="${DEPEND}"
-
-need_php_by_category
diff --git a/dev-php5/pecl-ssh2/pecl-ssh2-0.11.2.ebuild b/dev-php5/pecl-ssh2/pecl-ssh2-0.11.2.ebuild
new file mode 100644
index 000000000000..165fb77b76f0
--- /dev/null
+++ b/dev-php5/pecl-ssh2/pecl-ssh2-0.11.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-ssh2/pecl-ssh2-0.11.2.ebuild,v 1.1 2010/11/04 16:00:47 mabi Exp $
+
+PHP_EXT_NAME="ssh2"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README ChangeLog"
+
+inherit php-ext-pecl-r1
+
+DESCRIPTION="Provides bindings to the functions of libssh2 which implements the SSH2 protocol."
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+DEPEND=">=net-libs/libssh2-0.18
+ dev-lang/php"
+RDEPEND="${DEPEND}"