summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-23 22:33:19 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-23 22:33:19 +0000
commit1604fcb97f93f2cc1b51df5cb15998b330587aff (patch)
treebf18c912f909803c16408fcad2734c6b95b1efb9 /dev-php5
parentInitial import. Many thanks to all the contributors on bug 192561. Moved from... (diff)
downloadgentoo-2-1604fcb97f93f2cc1b51df5cb15998b330587aff.tar.gz
gentoo-2-1604fcb97f93f2cc1b51df5cb15998b330587aff.tar.bz2
gentoo-2-1604fcb97f93f2cc1b51df5cb15998b330587aff.zip
Initial imprort of PHP support for gearman. Thanks to Pavel Stratil once again for the ebuil.
(Portage version: 2.2_rc60/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/pecl-gearman/ChangeLog11
-rw-r--r--dev-php5/pecl-gearman/metadata.xml12
-rw-r--r--dev-php5/pecl-gearman/pecl-gearman-0.6.0.ebuild21
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-php5/pecl-gearman/ChangeLog b/dev-php5/pecl-gearman/ChangeLog
new file mode 100644
index 000000000000..1296877f3701
--- /dev/null
+++ b/dev-php5/pecl-gearman/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-php5/pecl-gearman
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-gearman/ChangeLog,v 1.1 2009/12/23 22:33:19 flameeyes Exp $
+
+*pecl-gearman-0.6.0 (23 Dec 2009)
+
+ 23 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +pecl-gearman-0.6.0.ebuild, +metadata.xml:
+ Initial imprort of PHP support for gearman. Thanks to Pavel Stratil once
+ again for the ebuil.
+
diff --git a/dev-php5/pecl-gearman/metadata.xml b/dev-php5/pecl-gearman/metadata.xml
new file mode 100644
index 000000000000..e12def24c0a2
--- /dev/null
+++ b/dev-php5/pecl-gearman/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>pavel.stratil-jun@fenix.cz</email>
+ <description>Proxied co-maintainer, CC on all bugs</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-php5/pecl-gearman/pecl-gearman-0.6.0.ebuild b/dev-php5/pecl-gearman/pecl-gearman-0.6.0.ebuild
new file mode 100644
index 000000000000..b6d5d972f955
--- /dev/null
+++ b/dev-php5/pecl-gearman/pecl-gearman-0.6.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-gearman/pecl-gearman-0.6.0.ebuild,v 1.1 2009/12/23 22:33:19 flameeyes Exp $
+
+PHP_EXT_NAME="gearman"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="PHP extension for using gearmand."
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="sys-cluster/gearmand"
+RDEPEND="${DEPEND}"
+
+need_php_by_category