summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-10-22 22:35:27 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-10-22 22:35:27 +0000
commit8757acebf307b2cc7fbf79132906815d8329b483 (patch)
treed4a56d1655d76bfac37c83d45c7c5e68674f6105 /dev-php5/phpunit
parentRemove old versions. Mark stable on x86. Version bump. (diff)
downloadgentoo-2-8757acebf307b2cc7fbf79132906815d8329b483.tar.gz
gentoo-2-8757acebf307b2cc7fbf79132906815d8329b483.tar.bz2
gentoo-2-8757acebf307b2cc7fbf79132906815d8329b483.zip
Version bump from php overlay
(Portage version: 2.1.3.15)
Diffstat (limited to 'dev-php5/phpunit')
-rw-r--r--dev-php5/phpunit/ChangeLog11
-rw-r--r--dev-php5/phpunit/files/digest-phpunit-3.1.83
-rw-r--r--dev-php5/phpunit/phpunit-3.1.8.ebuild36
3 files changed, 49 insertions, 1 deletions
diff --git a/dev-php5/phpunit/ChangeLog b/dev-php5/phpunit/ChangeLog
index 441139da26ea..f53f5f3e11b9 100644
--- a/dev-php5/phpunit/ChangeLog
+++ b/dev-php5/phpunit/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-php5/phpunit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.6 2007/08/27 10:26:47 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.7 2007/10/22 22:35:26 jokey Exp $
+
+*phpunit-3.1.8 (22 Oct 2007)
+
+ 22 Oct 2007; Markus Ullmann <jokey@gentoo.org> +phpunit-3.1.8.ebuild:
+ Version bump from php overlay
+
+ 29 Sep 2007; Jakub Moc <jakub@gentoo.org> +metadata.xml,
+ +phpunit-3.1.8.ebuild:
+ Version bump, remove references to pdo-external use flag
*phpunit-3.1.7 (27 Aug 2007)
*phpunit-3.0.6 (27 Aug 2007)
diff --git a/dev-php5/phpunit/files/digest-phpunit-3.1.8 b/dev-php5/phpunit/files/digest-phpunit-3.1.8
new file mode 100644
index 000000000000..ff9da590bcb3
--- /dev/null
+++ b/dev-php5/phpunit/files/digest-phpunit-3.1.8
@@ -0,0 +1,3 @@
+MD5 17cb76d972afc116e780c03c9a1835ec PHPUnit-3.1.8.tgz 116960
+RMD160 772b1aa5f57e4d05ddace89b44069c58b2663825 PHPUnit-3.1.8.tgz 116960
+SHA256 e47a3f609447226bec0ed2a2b4d2022540d272432cd33fe3e59253d8e736a9f6 PHPUnit-3.1.8.tgz 116960
diff --git a/dev-php5/phpunit/phpunit-3.1.8.ebuild b/dev-php5/phpunit/phpunit-3.1.8.ebuild
new file mode 100644
index 000000000000..7980e16b47ed
--- /dev/null
+++ b/dev-php5/phpunit/phpunit-3.1.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/phpunit-3.1.8.ebuild,v 1.1 2007/10/22 22:35:26 jokey Exp $
+
+inherit php-pear-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Unit Testing framework for PHP 5."
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND="!dev-php4/phpunit"
+RDEPEND="${DEPEND}
+ !minimal? ( >=dev-php5/xdebug-2.0.0_rc2
+ >=dev-php/PEAR-Image_GraphViz-1.2.1
+ >=dev-php/PEAR-Log-1.8.7-r1
+ >=dev-php/PEAR-Testing_Selenium-0.2.0 )"
+
+S="${WORKDIR}/PHPUnit-${PV}"
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+ require_php_with_use pcre reflection spl xml tokenizer
+}
+
+pkg_postinst() {
+ has_php
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge ${PHP_PKG} with USE=\"json pdo sqlite mysql\"."
+}