summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-03-28 19:03:45 +0000
committerMatti Bickel <mabi@gentoo.org>2010-03-28 19:03:45 +0000
commitf771934320fd39070ad972531c9fc5506eec7098 (patch)
treef8cbb31935d57becb6587d7297aee7673defc384 /dev-php5/pecl-gnupg
parentAdd ~arm/~s390/~sh/~sparc wrt #306633 (diff)
downloadgentoo-2-f771934320fd39070ad972531c9fc5506eec7098.tar.gz
gentoo-2-f771934320fd39070ad972531c9fc5506eec7098.tar.bz2
gentoo-2-f771934320fd39070ad972531c9fc5506eec7098.zip
segf&build fixes
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'dev-php5/pecl-gnupg')
-rw-r--r--dev-php5/pecl-gnupg/ChangeLog11
-rw-r--r--dev-php5/pecl-gnupg/files/1.3.1/01-large_file_system.patch9
-rw-r--r--dev-php5/pecl-gnupg/files/1.3.1/02-gpgme_new_seg_fault.patch10
-rw-r--r--dev-php5/pecl-gnupg/pecl-gnupg-1.3.1-r1.ebuild29
4 files changed, 57 insertions, 2 deletions
diff --git a/dev-php5/pecl-gnupg/ChangeLog b/dev-php5/pecl-gnupg/ChangeLog
index 8b6f4fa55fcc..7fcc8b83dd15 100644
--- a/dev-php5/pecl-gnupg/ChangeLog
+++ b/dev-php5/pecl-gnupg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-php5/pecl-gnupg
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-gnupg/ChangeLog,v 1.2 2008/06/09 19:40:02 swegener Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-gnupg/ChangeLog,v 1.3 2010/03/28 19:03:44 mabi Exp $
+
+*pecl-gnupg-1.3.1-r1 (28 Mar 2010)
+
+ 28 Mar 2010; <mabi@gentoo.org> +files/1.3.1/01-large_file_system.patch,
+ +pecl-gnupg-1.3.1-r1.ebuild, +files/1.3.1/02-gpgme_new_seg_fault.patch:
+ fix segfault and build error with gpgme-1.2 (bug #302446) thanks to Jamie
+ Learmonth
09 Jun 2008; Sven Wegener <swegener@gentoo.org> pecl-gnupg-1.3.1.ebuild:
Set RDEPEND="${DEPEND}"
diff --git a/dev-php5/pecl-gnupg/files/1.3.1/01-large_file_system.patch b/dev-php5/pecl-gnupg/files/1.3.1/01-large_file_system.patch
new file mode 100644
index 000000000000..4e64e3ccef1a
--- /dev/null
+++ b/dev-php5/pecl-gnupg/files/1.3.1/01-large_file_system.patch
@@ -0,0 +1,9 @@
+--- config.m4 2007-05-04 13:23:41.000000000 +0000
++++ config.m4.new 2010-03-28 01:13:10.000000000 +0000
+@@ -41,4 +41,6 @@
+ PHP_SUBST(GNUPG_SHARED_LIBADD)
+
+ PHP_NEW_EXTENSION(gnupg, [gnupg.c gnupg_keylistiterator.c], $ext_shared)
++
++ AC_SYS_LARGEFILE
+ fi
diff --git a/dev-php5/pecl-gnupg/files/1.3.1/02-gpgme_new_seg_fault.patch b/dev-php5/pecl-gnupg/files/1.3.1/02-gpgme_new_seg_fault.patch
new file mode 100644
index 000000000000..4ecb2a2a677a
--- /dev/null
+++ b/dev-php5/pecl-gnupg/files/1.3.1/02-gpgme_new_seg_fault.patch
@@ -0,0 +1,10 @@
+--- ./gnupg.c.old 2007-05-04 17:23:41.000000000 +0400
++++ ./gnupg.c 2010-01-27 15:04:04.000000000 +0300
+@@ -136,6 +136,7 @@
+ static void gnupg_res_init(gnupg_object *intern TSRMLS_DC){
+ /* init the gpgme-lib and set the default values */
+ gpgme_ctx_t ctx;
++ gpgme_check_version (0);
+ gpgme_new (&ctx);
+ gpgme_set_armor (ctx,1);
+ intern->ctx = ctx;
diff --git a/dev-php5/pecl-gnupg/pecl-gnupg-1.3.1-r1.ebuild b/dev-php5/pecl-gnupg/pecl-gnupg-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..14a7f8e7fdb7
--- /dev/null
+++ b/dev-php5/pecl-gnupg/pecl-gnupg-1.3.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-gnupg/pecl-gnupg-1.3.1-r1.ebuild,v 1.1 2010/03/28 19:03:44 mabi Exp $
+
+PHP_EXT_NAME="gnupg"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+EAPI="2"
+
+inherit php-ext-pecl-r1 eutils
+
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="PHP wrapper around the gpgme library"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="app-crypt/gpgme"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+src_prepare() {
+ cd ${S}
+ epatch "${FILESDIR}"/"${PV}"/01-large_file_system.patch
+ epatch "${FILESDIR}"/"${PV}"/02-gpgme_new_seg_fault.patch
+ eautoreconf
+}