summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-07-29 14:16:40 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-07-29 14:16:40 +0000
commitb8296bf94e4037a8794c3cb498e0a0901b71925c (patch)
treefa8f67597b277e5c55a8c84d5917cb98a51f26f1 /dev-php/xdebug-client
parentUnmask tb/fx/sm-bin on 64bit-native since they now install 64-bit binary tarb... (diff)
downloadgentoo-2-b8296bf94e4037a8794c3cb498e0a0901b71925c.tar.gz
gentoo-2-b8296bf94e4037a8794c3cb498e0a0901b71925c.tar.bz2
gentoo-2-b8296bf94e4037a8794c3cb498e0a0901b71925c.zip
Version bump
(Portage version: 2.1.10.6/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/xdebug-client')
-rw-r--r--dev-php/xdebug-client/ChangeLog8
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.1.2.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-php/xdebug-client/ChangeLog b/dev-php/xdebug-client/ChangeLog
index 74194634b76f..91fcb9c02443 100644
--- a/dev-php/xdebug-client/ChangeLog
+++ b/dev-php/xdebug-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/xdebug-client
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.28 2011/03/28 17:00:40 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.29 2011/07/29 14:16:40 olemarkus Exp $
+
+*xdebug-client-2.1.2 (29 Jul 2011)
+
+ 29 Jul 2011; Ole Markus With <olemarkus@gentoo.org>
+ +xdebug-client-2.1.2.ebuild:
+ Version bump
*xdebug-client-2.1.1 (28 Mar 2011)
diff --git a/dev-php/xdebug-client/xdebug-client-2.1.2.ebuild b/dev-php/xdebug-client/xdebug-client-2.1.2.ebuild
new file mode 100644
index 000000000000..1b04cef3bb43
--- /dev/null
+++ b/dev-php/xdebug-client/xdebug-client-2.1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.1.2.ebuild,v 1.1 2011/07/29 14:16:40 olemarkus Exp $
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE="libedit"
+
+S="${WORKDIR}/xdebug-${MY_PV}/debugclient"
+
+DEPEND="libedit? ( dev-libs/libedit )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ chmod +x "${S}"/configure
+}
+
+src_compile() {
+ econf $(use_with libedit) --disable-dependency-tracking
+ emake || die "Build of debug client failed!"
+}
+
+src_install() {
+ newbin debugclient xdebug
+}