summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-05-30 10:02:29 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-05-30 10:02:29 +0000
commit0572afde8a7a4c55d0e26b54b88708e99f1b26ee (patch)
treec35a89f2b56e50d194d53920c33e262fd5ec4f9c /dev-php/phpunit
parentDrop libX11 mask. (diff)
downloadgentoo-2-0572afde8a7a4c55d0e26b54b88708e99f1b26ee.tar.gz
gentoo-2-0572afde8a7a4c55d0e26b54b88708e99f1b26ee.tar.bz2
gentoo-2-0572afde8a7a4c55d0e26b54b88708e99f1b26ee.zip
Version bump
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/phpunit')
-rw-r--r--dev-php/phpunit/ChangeLog7
-rw-r--r--dev-php/phpunit/phpunit-3.6.10.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-php/phpunit/ChangeLog b/dev-php/phpunit/ChangeLog
index 34849f0cca42..4ea88fa88d1d 100644
--- a/dev-php/phpunit/ChangeLog
+++ b/dev-php/phpunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/phpunit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpunit/ChangeLog,v 1.10 2012/03/10 16:47:40 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpunit/ChangeLog,v 1.11 2012/05/30 10:02:29 olemarkus Exp $
+
+*phpunit-3.6.10 (30 May 2012)
+
+ 30 May 2012; Ole Markus With <olemarkus@gentoo.org> +phpunit-3.6.10.ebuild:
+ Version bump
10 Mar 2012; Ole Markus With <olemarkus@gentoo.org> phpunit-3.5.13.ebuild:
Fixing deps on DBUnit
diff --git a/dev-php/phpunit/phpunit-3.6.10.ebuild b/dev-php/phpunit/phpunit-3.6.10.ebuild
new file mode 100644
index 000000000000..6a893cfaa238
--- /dev/null
+++ b/dev-php/phpunit/phpunit-3.6.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpunit/phpunit-3.6.10.ebuild,v 1.1 2012/05/30 10:02:29 olemarkus Exp $
+
+EAPI="4"
+PHP_PEAR_CHANNEL="${FILESDIR}/channel.xml"
+PHP_PEAR_PN="PHPUnit"
+
+PHP_PEAR_URI="pear.phpunit.de"
+inherit php-pear-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Unit testing framework for PHP5"
+HOMEPAGE="http://www.phpunit.de/"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-php/PEAR-PEAR-1.9.1"
+RDEPEND="${DEPEND}
+ dev-lang/php
+ >=dev-php/Text_Template-1.1.1
+ >=dev-php/PHP_CodeCoverage-1.1.0
+ >=dev-php/PHP_Timer-1.0.1
+ >=dev-php/PHPUnit_MockObject-1.1.0
+ >=dev-php/File_Iterator-1.3.0
+ >=dev-php/YAML-1.0.2"
+
+pkg_postinst() {
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge dev-lang/php with USE=\"json pdo sqlite mysql\"."
+}