summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-04-05 20:59:52 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-04-05 20:59:52 +0000
commit124592cad1baf5980e55c8f50f6dec4058ed0305 (patch)
tree451c6b353cbaaafc3989c3435b95da697b3a3018 /dev-php/php-cgi
parentbump to new rc as 4.3.5 has issues (Manifest recommit) (diff)
downloadgentoo-2-124592cad1baf5980e55c8f50f6dec4058ed0305.tar.gz
gentoo-2-124592cad1baf5980e55c8f50f6dec4058ed0305.tar.bz2
gentoo-2-124592cad1baf5980e55c8f50f6dec4058ed0305.zip
remove old ebuild using php-2 eclass, and mark 4.3.4r2 as stable.
Diffstat (limited to 'dev-php/php-cgi')
-rw-r--r--dev-php/php-cgi/ChangeLog6
-rw-r--r--dev-php/php-cgi/files/digest-php-cgi-4.3.42
-rw-r--r--dev-php/php-cgi/php-cgi-4.3.4-r2.ebuild4
-rw-r--r--dev-php/php-cgi/php-cgi-4.3.4.ebuild55
4 files changed, 7 insertions, 60 deletions
diff --git a/dev-php/php-cgi/ChangeLog b/dev-php/php-cgi/ChangeLog
index 70166982de8d..c992d19094f0 100644
--- a/dev-php/php-cgi/ChangeLog
+++ b/dev-php/php-cgi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/php-cgi
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/ChangeLog,v 1.5 2004/04/05 20:56:12 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/ChangeLog,v 1.6 2004/04/05 20:59:52 robbat2 Exp $
+
+ 05 Apr 2004; Robin H. Johnson <robbat2@gentoo.org> php-cgi-4.3.4-r2.ebuild,
+ php-cgi-4.3.4.ebuild:
+ remove old ebuild using php-2 eclass, and mark 4.3.4r2 as stable.
*php-cgi-4.3.6_rc2 (05 Apr 2004)
diff --git a/dev-php/php-cgi/files/digest-php-cgi-4.3.4 b/dev-php/php-cgi/files/digest-php-cgi-4.3.4
deleted file mode 100644
index d65ce9576341..000000000000
--- a/dev-php/php-cgi/files/digest-php-cgi-4.3.4
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 b9dd601863e08e52e3c4d5e02c2627cf php-4.3.4.tar.bz2 3774324
-MD5 912ff94309b762563d0542db5187315f php-4.3.2-fopen-url-secure.patch 416
diff --git a/dev-php/php-cgi/php-cgi-4.3.4-r2.ebuild b/dev-php/php-cgi/php-cgi-4.3.4-r2.ebuild
index ddc1b2272b7c..bc565ebaeb9f 100644
--- a/dev-php/php-cgi/php-cgi-4.3.4-r2.ebuild
+++ b/dev-php/php-cgi/php-cgi-4.3.4-r2.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/php-cgi-4.3.4-r2.ebuild,v 1.2 2004/01/08 06:37:38 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/php-cgi-4.3.4-r2.ebuild,v 1.3 2004/04/05 20:59:52 robbat2 Exp $
PHPSAPI="cgi"
inherit php-sapi eutils
DESCRIPTION="PHP CGI"
SLOT="0"
-KEYWORDS="x86 ~ppc ~sparc ~alpha ~hppa"
+KEYWORDS="x86 ppc sparc alpha hppa"
src_compile() {
# CLI needed to build stuff
diff --git a/dev-php/php-cgi/php-cgi-4.3.4.ebuild b/dev-php/php-cgi/php-cgi-4.3.4.ebuild
deleted file mode 100644
index 1f8bf48ba6b9..000000000000
--- a/dev-php/php-cgi/php-cgi-4.3.4.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/php-cgi-4.3.4.ebuild,v 1.3 2004/01/08 06:37:38 robbat2 Exp $
-
-PHPSAPI="cgi"
-inherit php-2 eutils
-
-IUSE="${IUSE} readline"
-
-DESCRIPTION="PHP CGI"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
-
-DEPEND_EXTRA="readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
- ncurses? ( >=sys-libs/ncurses-5.1 )"
-DEPEND="${DEPEND} ${DEPEND_EXTRA}"
-RDEPEND="${RDEPEND} ${DEPEND_EXTRA}"
-PDEPEND="${PDEPEND} ~dev-php/php-core-${PV}"
-PROVIDE="virtual/php-4.3.4"
-
-
-src_compile() {
- myconf="${myconf} `use_with readline readline /usr`"
- # Readline and Ncurses are CLI PHP only
- # readline needs ncurses
- use ncurses || use readline \
- && myconf="${myconf} --with-ncurses=/usr" \
- || myconf="${myconf} --without-ncurses"
-
- # CLI needed to build stuff
- myconf="${myconf} \
- --enable-cgi \
- --enable-cli \
- --enable-fastcgi"
-
- php_src_compile
-}
-
-
-src_install() {
- installtargets="${installtargets} install-cgi install-sapi"
- php_src_install
-
- # php executable is located in ./sapi/cli/
- exeinto /usr/bin
- newexe sapi/cgi/php php-cgi
-}
-
-pkg_postinst() {
- php_pkg_postinst
- einfo "This is a CGI only build."
-}
-pkg_preinst() {
- php_pkg_preinst
-}