summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-03-29 11:00:27 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-03-29 11:00:27 +0000
commit83857ddc927bd6fb9a1b932972cf89e2e6baf205 (patch)
tree1cad6848a9750620df5a57e918a29035d3e354d8 /dev-php/mod_php
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-83857ddc927bd6fb9a1b932972cf89e2e6baf205.tar.gz
gentoo-2-83857ddc927bd6fb9a1b932972cf89e2e6baf205.tar.bz2
gentoo-2-83857ddc927bd6fb9a1b932972cf89e2e6baf205.zip
need a second revision for an apache1 fix
Diffstat (limited to 'dev-php/mod_php')
-rw-r--r--dev-php/mod_php/ChangeLog5
-rw-r--r--dev-php/mod_php/files/mod_php-4.3.5-apache1security.diff12
-rw-r--r--dev-php/mod_php/mod_php-4.3.5.ebuild6
3 files changed, 19 insertions, 4 deletions
diff --git a/dev-php/mod_php/ChangeLog b/dev-php/mod_php/ChangeLog
index 0f3d33d1c410..91485d829996 100644
--- a/dev-php/mod_php/ChangeLog
+++ b/dev-php/mod_php/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-php/mod_php
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.131 2004/03/29 10:42:30 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.132 2004/03/29 11:00:27 robbat2 Exp $
+
+ 29 Mar 2004; Robin H. Johnson <robbat2@gentoo.org> mod_php-4.3.5.ebuild:
+ need a second revision for an apache1 fix
29 Mar 2004; Robin H. Johnson <robbat2@gentoo.org> mod_php-4.3.5.ebuild:
fix bug #46048 for new php
diff --git a/dev-php/mod_php/files/mod_php-4.3.5-apache1security.diff b/dev-php/mod_php/files/mod_php-4.3.5-apache1security.diff
new file mode 100644
index 000000000000..373038097cf6
--- /dev/null
+++ b/dev-php/mod_php/files/mod_php-4.3.5-apache1security.diff
@@ -0,0 +1,12 @@
+--- php-4.3.5/sapi/apache/mod_php4.c.old 2004-01-31 21:44:55.000000000 +0000
++++ php-4.3.5/sapi/apache/mod_php4.c 2004-01-31 21:49:59.000000000 +0000
+@@ -822,6 +822,9 @@
+
+ if (!(r->finfo.st_mode & S_IXUSR)) {
+ r->allowed |= (1 << METHODS) - 1;
++ zend_try {
++ zend_ini_deactivate(TSRMLS_C);
++ } zend_end_try();
+ return DECLINED;
+ }
+ per_dir_conf = (HashTable *) get_module_config(r->per_dir_config, &php4_module);
diff --git a/dev-php/mod_php/mod_php-4.3.5.ebuild b/dev-php/mod_php/mod_php-4.3.5.ebuild
index 8accb7869ce6..84c28600502c 100644
--- a/dev-php/mod_php/mod_php-4.3.5.ebuild
+++ b/dev-php/mod_php/mod_php-4.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.5.ebuild,v 1.2 2004/03/29 10:42:30 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.5.ebuild,v 1.3 2004/03/29 11:00:27 robbat2 Exp $
IUSE="${IUSE} apache2"
@@ -71,8 +71,8 @@ src_unpack() {
fi
# bug fix for security problem - bug #39952
- # integrated upstream now
- #epatch ${FILESDIR}/mod_php-4.3.4-r3.diff
+ # second revision as the apache2 stuff was resolved upstream
+ epatch ${FILESDIR}/mod_php-4.3.5-apache1security.diff
# stop php from activing the apache config, as we will do that ourselves
for i in configure sapi/apache/config.m4 sapi/apache2filter/config.m4 sapi/apache2handler/config.m4; do