summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2011-03-23 17:15:51 +0000
committerChristian Ruppert <idl0r@gentoo.org>2011-03-23 17:15:51 +0000
commit122de31122b8097278ffa23be053df1155ca9d96 (patch)
treeb61660e0f6fa67a990de751b82e6fa9dfe98bf76 /dev-perl
parentChange the location in which we search for mbrola. (diff)
downloadgentoo-2-122de31122b8097278ffa23be053df1155ca9d96.tar.gz
gentoo-2-122de31122b8097278ffa23be053df1155ca9d96.tar.bz2
gentoo-2-122de31122b8097278ffa23be053df1155ca9d96.zip
Add a patch to use read() instead of sysread() when using mod_perl, https://rt.cpan.org/Public/Bug/Display.html?id=58538 Switch to EAPI 3, set RDEPEND.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/SOAP-Lite/ChangeLog8
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-0.712.ebuild12
-rw-r--r--dev-perl/SOAP-Lite/files/SOAP-Lite-0.712_sysread.patch38
3 files changed, 52 insertions, 6 deletions
diff --git a/dev-perl/SOAP-Lite/ChangeLog b/dev-perl/SOAP-Lite/ChangeLog
index f20794019e84..126c98ea5912 100644
--- a/dev-perl/SOAP-Lite/ChangeLog
+++ b/dev-perl/SOAP-Lite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/SOAP-Lite
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.65 2011/01/14 16:38:50 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.66 2011/03/23 17:15:51 idl0r Exp $
+
+ 23 Mar 2011; Christian Ruppert <idl0r@gentoo.org> SOAP-Lite-0.712.ebuild,
+ +files/SOAP-Lite-0.712_sysread.patch:
+ Add a patch to use read() instead of sysread() when using mod_perl,
+ https://rt.cpan.org/Public/Bug/Display.html?id=58538 Switch to EAPI 3, set
+ RDEPEND.
14 Jan 2011; Torsten Veller <tove@gentoo.org> -SOAP-Lite-0.710.10.ebuild:
Cleanup
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-0.712.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-0.712.ebuild
index e7c6da0c8346..1bc8ce7e7567 100644
--- a/dev-perl/SOAP-Lite/SOAP-Lite-0.712.ebuild
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-0.712.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/SOAP-Lite-0.712.ebuild,v 1.2 2010/10/27 20:13:08 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/SOAP-Lite-0.712.ebuild,v 1.3 2011/03/23 17:15:51 idl0r Exp $
+
+EAPI="3"
MODULE_AUTHOR="MKUTTER"
inherit perl-module eutils
@@ -34,15 +36,15 @@ DEPEND="dev-perl/Class-Inspector
>=dev-perl/MIME-tools-5.413
virtual/perl-version
dev-lang/perl"
+RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
# The author of this module put a dep for MIME::Parser 6.X - but the6.X
# release of MIME::Parser was a mistake during a change in maintainers on
# cpan. This patch alters the dependancy to the "real" stable version of
# MIME::Parser.
epatch "${FILESDIR}"/SOAP-Lite-0.710.08.patch
+ epatch "${FILESDIR}"/${P}_sysread.patch
}
src_test() {
diff --git a/dev-perl/SOAP-Lite/files/SOAP-Lite-0.712_sysread.patch b/dev-perl/SOAP-Lite/files/SOAP-Lite-0.712_sysread.patch
new file mode 100644
index 000000000000..85289fcadaad
--- /dev/null
+++ b/dev-perl/SOAP-Lite/files/SOAP-Lite-0.712_sysread.patch
@@ -0,0 +1,38 @@
+From 8f49c0e970261f59bc043a8104a9a730ec69dcf4 Mon Sep 17 00:00:00 2001
+From: Christian Ruppert <idl0r@gentoo.org>
+Date: Wed, 23 Mar 2011 18:04:19 +0100
+Subject: [PATCH] Use read() instead of sysread() when using mod_perl
+
+https://rt.cpan.org/Public/Bug/Display.html?id=58538
+---
+ lib/SOAP/Transport/HTTP.pm | 14 +++++++++++---
+ 1 files changed, 11 insertions(+), 3 deletions(-)
+
+diff --git a/lib/SOAP/Transport/HTTP.pm b/lib/SOAP/Transport/HTTP.pm
+index f16b990..57ebbf3 100644
+--- a/lib/SOAP/Transport/HTTP.pm
++++ b/lib/SOAP/Transport/HTTP.pm
+@@ -566,9 +566,17 @@ sub handle {
+ if ( !$chunked ) {
+ my $buffer;
+ binmode(STDIN);
+- while ( sysread( STDIN, $buffer, $length ) ) {
+- $content .= $buffer;
+- last if ( length($content) >= $length );
++ if ( defined($ENV{"MOD_PERL"}) ) {
++ while ( read( STDIN, $buffer, $length ) ) {
++ $content .= $buffer;
++ last if ( length($content) >= $length );
++ }
++ }
++ else {
++ while ( sysread( STDIN, $buffer, $length ) ) {
++ $content .= $buffer;
++ last if ( length($content) >= $length );
++ }
+ }
+ }
+
+--
+1.7.3.4
+