summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-09-30 14:09:44 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-09-30 14:09:44 +0000
commitf7e6a918871d59b72b70037d8eb7396b21c9a9bc (patch)
tree3fbfbc3786fedb5607a32fd6a40850c2352f148a /dev-perl/dbix-searchbuilder/dbix-searchbuilder-1.45.ebuild
parentVersion bump. (diff)
downloadgentoo-2-f7e6a918871d59b72b70037d8eb7396b21c9a9bc.tar.gz
gentoo-2-f7e6a918871d59b72b70037d8eb7396b21c9a9bc.tar.bz2
gentoo-2-f7e6a918871d59b72b70037d8eb7396b21c9a9bc.zip
Version bump
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'dev-perl/dbix-searchbuilder/dbix-searchbuilder-1.45.ebuild')
-rw-r--r--dev-perl/dbix-searchbuilder/dbix-searchbuilder-1.45.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/dbix-searchbuilder/dbix-searchbuilder-1.45.ebuild b/dev-perl/dbix-searchbuilder/dbix-searchbuilder-1.45.ebuild
new file mode 100644
index 000000000000..2e9aa2a133a5
--- /dev/null
+++ b/dev-perl/dbix-searchbuilder/dbix-searchbuilder-1.45.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/dbix-searchbuilder/dbix-searchbuilder-1.45.ebuild,v 1.1 2006/09/30 14:09:44 mcummings Exp $
+
+inherit perl-module
+
+MY_P=DBIx-SearchBuilder-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Encapsulate SQL queries and rows in simple perl objects"
+SRC_URI="mirror://cpan/authors/id/J/JE/JESSE/${MY_P}.tar.gz"
+HOMEPAGE="http://www.cpan.org/authors/id/J/JE/JESSE/"
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+#KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+SRC_TEST="do"
+
+DEPEND="dev-perl/DBD-SQLite
+ >=virtual/perl-Test-Simple-0.52
+ dev-lang/perl"
+
+RDEPEND="dev-perl/DBI
+ dev-perl/DBIx-DBSchema
+ dev-perl/Want
+ >=dev-perl/Cache-Simple-TimedExpiry-0.21
+ dev-perl/Clone
+ dev-perl/Class-Accessor
+ >=dev-perl/capitalization-0.03
+ >=dev-perl/class-returnvalue-0.4"
+
+
+