summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-04-28 18:59:13 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-04-28 18:59:13 +0000
commit5ac10850a782371e572836aea69446479004716e (patch)
treec3c0302e994039c14127292babcbc33b14cc05d1 /dev-perl/SVN-Simple/SVN-Simple-0.27.ebuild
parentCleaning (diff)
downloadgentoo-2-5ac10850a782371e572836aea69446479004716e.tar.gz
gentoo-2-5ac10850a782371e572836aea69446479004716e.tar.bz2
gentoo-2-5ac10850a782371e572836aea69446479004716e.zip
cleaning
(Portage version: 2.0.51.20-r4)
Diffstat (limited to 'dev-perl/SVN-Simple/SVN-Simple-0.27.ebuild')
-rw-r--r--dev-perl/SVN-Simple/SVN-Simple-0.27.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/SVN-Simple/SVN-Simple-0.27.ebuild b/dev-perl/SVN-Simple/SVN-Simple-0.27.ebuild
new file mode 100644
index 000000000000..30e77f6157f0
--- /dev/null
+++ b/dev-perl/SVN-Simple/SVN-Simple-0.27.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SVN-Simple/SVN-Simple-0.27.ebuild,v 1.1 2005/04/28 18:59:13 mcummings Exp $
+
+inherit perl-module
+
+DESCRIPTION="SVN::Simple::Edit - Simple interface to SVN::Delta::Editor"
+SRC_URI="mirror://cpan/authors/id/C/CL/CLKAO/${P}.tar.gz"
+HOMEPAGE="http://www.cpan.org/authors/id/C/CL/CLKAO/${P}.readme"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="${DEPEND}
+ >=dev-util/subversion-0.31"
+
+pkg_setup() {
+ if ! perl -MSVN::Core < /dev/null 2> /dev/null
+ then
+ eerror "You need subversion-0.31+ compiled with Perl bindings."
+ eerror "USE=\"perl\" emerge subversion"
+ die "Need Subversion compiled with Perl bindings."
+ fi
+}