summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-08-23 17:55:47 +0000
committerTorsten Veller <tove@gentoo.org>2008-08-23 17:55:47 +0000
commitfc8a42594f7e4ab7fc1af157b0ca9389c2d35e42 (patch)
tree310ff2c271feecf9e8fdbec5116f52a1d6b9c24d /dev-perl/Error/Error-0.17.015.ebuild
parentadd ~amd64, bug #211550 (diff)
downloadgentoo-2-fc8a42594f7e4ab7fc1af157b0ca9389c2d35e42.tar.gz
gentoo-2-fc8a42594f7e4ab7fc1af157b0ca9389c2d35e42.tar.bz2
gentoo-2-fc8a42594f7e4ab7fc1af157b0ca9389c2d35e42.zip
Version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-tuxonice i686)
Diffstat (limited to 'dev-perl/Error/Error-0.17.015.ebuild')
-rw-r--r--dev-perl/Error/Error-0.17.015.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/Error/Error-0.17.015.ebuild b/dev-perl/Error/Error-0.17.015.ebuild
new file mode 100644
index 000000000000..29981acfa061
--- /dev/null
+++ b/dev-perl/Error/Error-0.17.015.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Error/Error-0.17.015.ebuild,v 1.1 2008/08/23 17:55:47 tove Exp $
+
+inherit versionator perl-module
+
+MY_PV="$(delete_version_separator 2)"
+MY_P="${PN}-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Error/exception handling in an OO-ish way"
+HOMEPAGE="http://search.cpan.org/dist/Error/"
+SRC_URI="mirror://cpan/authors/id/S/SH/SHLOMIF/${MY_P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}
+ dev-perl/module-build
+ test? ( >=dev-perl/Test-Pod-1.14
+ >=dev-perl/Test-Pod-Coverage-1.04 )"
+
+SRC_TEST="do"